Jump to content


Photo

PDO (PHP Data Objects)


  • Please log in to reply
12 replies to this topic

#1 FrankJ

FrankJ

    Newbie

  • Member
  • Pip
  • 7 posts
  • Wiki ID: FrankJ
  • Main OS: Windows XP

Posted 28 January 2011 - 11:06 PM

I tried to load Drupal 7 on my Uniform Server 5.7.1 and get this message below. I apologize, but I have very little experience with the workings of a server. Should I go and download the PDO support files from MySQL? How hard is it to install? Will that mess up Uniform Server? I also found something on PHP.net that stated I just had to alter php.ini. I am not sure exactly which ones to enable. I have the Uniform Server running on a flash drive. My computer is running WindowsXP SP3 with 2Gb of ram, if that has anything to do with it. (and do I need to keep coming back here to keep seeing if anyone answers or is there an email notification? if needed knarfhill@embarqmail.com)

-----------------
Drupal message
Database support Disabled
Your web server does not appear to support any common PDO database extensions. Check with your hosting provider to see if they support PDO (PHP Data Objects) and offer any databases that Drupal supports Drupal supports.

#2 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 29 January 2011 - 06:33 AM

Drupal state the following:

For Apache, you will need to make sure php_pdo.dll and php_pdo_mysql.dll exist in the php/ext directory, un-comment or add the appropriate lines in php.ini, and restart the web server.

Note: The php_pdo.dll is pre-compiled into PHP 5.3.5 hence will not appear in the extensions folder.

Extension php_pdo_mysql.dll exists in the extensions folder however it needs to be enabled in php.ini configuration file. To enable perform the following:

Edit file:
UniServer\usr\local\php\php.ini
Locate this line:
;extension=php_pdo_mysql.dll
Un-comment the line (remove ; ) as shown below:
extension=php_pdo_mysql.dll

Enable InnoDB
Otherwise you will receive this error:
Syntax error or access violation: 1286 Unknown storage engine 'InnoDB'

Edit file:
UniServer\usr\local\mysql\my.ini
Locate this line:
skip-innodb
Comment line (add #) as shown below:
#skip-innodb

Finally: During installation use a real e-mail address otherwise install will fail.

Tested on: Nano 5.7.1 Drupal 7.0

All the best
Ric :)

#3 FrankJ

FrankJ

    Newbie

  • Member
  • Pip
  • 7 posts
  • Wiki ID: FrankJ
  • Main OS: Windows XP

Posted 29 January 2011 - 09:56 AM

Perfect! Thanks so much for the information and instructions - very simple and thorough. 10,000 thank yous.

#4 Ollie222

Ollie222

    Junior Member

  • Member
  • Pip
  • 15 posts
  • Main OS: Windows Vista

Posted 09 March 2011 - 09:05 AM

Just for the record the same process has worked for me using Uniserver 5.5.

Keep up the good work Ric, Uniserver really is becoming a very useful collection of tools.

#5 10basetom

10basetom

    Newbie

  • Member
  • Pip
  • 7 posts

Posted 13 March 2011 - 06:00 PM

Does this mean Drupal 7 *requires* InnoDB? I can see this being a problem for many people because most cheap hosts only support MyISAM.

#6 FrankJ

FrankJ

    Newbie

  • Member
  • Pip
  • 7 posts
  • Wiki ID: FrankJ
  • Main OS: Windows XP

Posted 13 March 2011 - 06:42 PM

"Note: Drupal supports MyISAM and InnoDB table types. NDB tables (MySQL Cluster) are not supported." From http://drupal.org/requirements. Drupal 5.x, 6.x, 7.x requirements page. And my uniformserver was not set up this way, thus the original question. I did as outlined above and D7 loaded just fine.

#7 10basetom

10basetom

    Newbie

  • Member
  • Pip
  • 7 posts

Posted 13 March 2011 - 06:45 PM

"Note: Drupal supports MyISAM and InnoDB table types. NDB tables (MySQL Cluster) are not supported." From http://drupal.org/requirements. Drupal 5.x, 6.x, 7.x requirements page. And my uniformserver was not set up this way, thus the original question. I did as outlined above and D7 loaded just fine.


Yup, I just installed Drupal 7 a minute ago and can confirm that nothing broke after ALTERing all the tables to ENGINE=MyISAM.

#8 Amonsa

Amonsa

    Newbie

  • Member
  • Pip
  • 2 posts
  • Main OS: Windows Vista

Posted 06 April 2011 - 03:52 AM

Thanks a lot for the help,
it works for me :(

#9 makantruzz

makantruzz

    Junior Member

  • Member
  • Pip
  • 11 posts
  • Main OS: Windows 7

Posted 16 September 2011 - 10:53 AM

how to check that pdo_mysql is activated ?? and how to test that my PHP is connected to pdo mysql ?

#10 rleroy

rleroy

    Newbie

  • Member
  • Pip
  • 5 posts
  • Main OS: Windows 7

Posted 23 September 2011 - 04:33 AM

Does this mean Drupal 7 *requires* InnoDB? I can see this being a problem for many people because most cheap hosts only support MyISAM.


I actually did not know that some web hosting provider do not support Drupal 7. I think I will contact the customer support of my web hosting provider and will check if they also support Drupal 7 but I think this should not be a problem.

#11 FrankJ

FrankJ

    Newbie

  • Member
  • Pip
  • 7 posts
  • Wiki ID: FrankJ
  • Main OS: Windows XP

Posted 04 October 2011 - 06:34 PM

I just did this with Uniform Server 7.1.11 Orion and Drupal D7 following Ric's information at the top of this thread. All works just fine.

#12 robie

robie

    Newbie

  • Member
  • Pip
  • 1 posts
  • Main OS: Windows Vista

Posted 19 October 2011 - 11:27 AM

Hi Ric,
I was having the same problem and followed your instructions but unfortunately still get this error message:
Error
Database support Disabled
Your web server does not appear to support any common PDO database extensions. Check with your hosting provider to see if they support PDO (PHP Data Objects) and offer any databases that Drupal supports.

Any ideas what I can try next please?

I'm using version Orion 7.1.12 on windows 7

Cheers
Rob


Drupal state the following:

For Apache, you will need to make sure php_pdo.dll and php_pdo_mysql.dll exist in the php/ext directory, un-comment or add the appropriate lines in php.ini, and restart the web server.

Note: The php_pdo.dll is pre-compiled into PHP 5.3.5 hence will not appear in the extensions folder.

Extension php_pdo_mysql.dll exists in the extensions folder however it needs to be enabled in php.ini configuration file. To enable perform the following:

Edit file:
UniServer\usr\local\php\php.ini
Locate this line:
;extension=php_pdo_mysql.dll
Un-comment the line (remove ; ) as shown below:
extension=php_pdo_mysql.dll

Enable InnoDB
Otherwise you will receive this error:
Syntax error or access violation: 1286 Unknown storage engine 'InnoDB'

Edit file:
UniServer\usr\local\mysql\my.ini
Locate this line:
skip-innodb
Comment line (add #) as shown below:
#skip-innodb

Finally: During installation use a real e-mail address otherwise install will fail.

Tested on: Nano 5.7.1 Drupal 7.0

All the best
Ric ;)



#13 vaalf

vaalf

    Newbie

  • Member
  • Pip
  • 1 posts
  • Main OS: Windows Vista

Posted 22 January 2012 - 11:03 AM

Hi Ric,
I was having the same problem and followed your instructions but unfortunately still get this error message:
Error
Database support Disabled
Your web server does not appear to support any common PDO database extensions. Check with your hosting provider to see if they support PDO (PHP Data Objects) and offer any databases that Drupal supports.

Any ideas what I can try next please?

I'm using version Orion 7.1.12 on windows 7

Cheers
Rob

Hi,

I had the very same issue with Orion 7.1.4 on Win 7. But I could manage to resolve the issue by manually restarting the Orion server. Maybe it is the trick for you as well!


Thanks,
Vaalf




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users