Jump to content


UniServer Zero Controller Menu > General > Mail Utility msmtp

uniserver zero uniserver zero controller msmtp

  • Please log in to reply
1 reply to this topic

#1 AboutUtila



  • Member
  • Pip
  • 5 posts
  • Main OS: Windows XP

Posted 21 September 2013 - 12:48 PM


Server OS: Windows XP SP3 (with latest updates as at 21-Sep-2013)

UniServer Zero Modules installed:

Zero_Controller_10_2_3.exe (with msmtp v1.4.31)









Problem Description:

In general, no significant problems - great product, thank you.


Except problems with Mail Utility msmtp when trying to run it from the controller application, Menu > General > Mail utility msmtp > Send Mail (button).

Problem is: No mail is sent, no C:\UniServerZ\core\msmtp\msmtp.log file is created.

(I had previously appropriately edited C:\UniServerZ\core\msmtp\msmtprc.ini using Menu > General > Mail utility msmtp > Edit configuration file and double checked that the edits had been saved, and stopped and restarted the controller)

Sending mail using C:\UniServerZ\core\msmtp\Send_test_email.bat works as expected (does not matter if Apache Server is running or not running)

Sending mail using a PHP script works as expected when Apache Server is running.



(1) Edited C:\UniServerZ\core\msmtp\Send_test_email.bat and changed the line,

msmtp --file=%cd%\msmtprc.ini user_name@target_email_address -t < %TEMP%\temp.mail

such that 'user_name@target_email_address' was a valid email address

(2) Ran the file Send_test_email.bat from the Windows command prompt

(3) Everything worked as expected, log file created (and contents shown in controller General > Mail utility msmtp > log file

(4) Tried again to Send Mail using the controller General > Mail utility msmtp > Send Mail, but nothing appears to happen

(5) From the controller Apache Utilities > Server Console



C:\UniServerZ>msmtp.exe -P
ignoring system configuration file C:\Documents and Settings\All Users\Application Data\msmtprc.txt: No such file or directory
ignoring user configuration file C:\UniServerZ\msmtprc.txt: No such file or directory
falling back to default account
msmtp.exe: account default not found: no configuration file available

C:\UniServerZ>msmtp.exe -S
msmtp.exe: account default not found: no configuration file available


Thank you.

#2 Ric


    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 22 September 2013 - 06:41 AM

Thanks for a very informative post. You have highlighted a bug, which I can confirm. The bug in the controller in addition I found minor issues with Send_test_email.bat and msmtprc.ini


These have been corrected in the new controller Zero_Controller_10_2_4.exe

Download the new controller and give it a spin.


All the best


Also tagged with one or more of these keywords: uniserver zero, uniserver zero controller, msmtp

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users