Jump to content


Photo

Mod rewrite problem


  • Please log in to reply
8 replies to this topic

#1 miniml

miniml

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 25 June 2005 - 05:11 AM

Hello,

When I try to use mod rewrite in my .htaccess file, I get:

"Forbidden
You don't have permission to access / on this server."

Rewrite rules doesn't matter, it happens with any rule, all it takes to happen is to turn it on: "RewriteEngine On"

#2 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 25 June 2005 - 08:00 AM

Here are the things that might be affecting this, a is that you have the DENY setting in the .htaccess or is that you are doing something wrong with the mod_rewrite code...

I will try and test it here... :D

Thanks

#3 miniml

miniml

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 25 June 2005 - 08:51 AM

Here are the things that might be affecting this, a is that you have the DENY setting in the .htaccess or is that you are doing something wrong with the mod_rewrite code...

View Post

Neither of above. My code works with all other WAMP packages out there.

I have installed Uniform Server as a Win service if that helps.

#4 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 25 June 2005 - 09:12 AM

I do not think that is the problem.. I got the same error while trying also and searched Google.

Here is what you need to do, shut down your server, edit the .htaccess file and enter this:

Options +FollowSymLinks 
RewriteEngine On

And then restart and it should work without a problem, i hope.. it worked on mine.. :D

Thanks...

#5 miniml

miniml

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 25 June 2005 - 11:03 AM

Yes, it works now with +FollowSymLinks, thanks!

#6 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 25 June 2005 - 11:44 AM

No Problem :( :D

#7 bebs

bebs

    Newbie

  • Member
  • Pip
  • 1 posts

Posted 04 August 2005 - 09:22 AM

Hello,

My problem is exactly the same, but I am not allowed to use the FollowSymLinks options, for it jams my application (namely WordPress blog for multiusers).

I could not figure why the RewriteRule seems to change the access rights in Uniform, and any hint would be appreciated!

Thanks a lot for this great package, as it is the one and first major problem I got after 1 year of extensive use, thanks !

#8 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 04 August 2005 - 11:38 AM

Why are you not allowed to use the FollowSymLinks option for the application?

I will try and search Google to find other ways that can help ...

#9 AlleyKat

AlleyKat

    Project Helper

  • Super Moderator
  • PipPip
  • 84 posts
  • Location:Odense, Denmark
  • SourceForge IDdk_alleykat
  • IRC Nickname: (@)AlleyKat :P

Posted 05 August 2005 - 09:14 AM

http://codex.wordpre...sing_Permalinks

As I recall its just putting the Options line before all the wordpress generated code in the file. It may also need a RewriteBase directive if run in a subfolder. I think there are a set of 'divider' comment lines in the .htaccess?




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users