Jump to content


Photo

Perl only parses in the command prompt


  • Please log in to reply
5 replies to this topic

#1 lvlr

lvlr

    Newbie

  • Member
  • Pip
  • 2 posts

Posted 02 May 2006 - 01:48 PM

I can get Perl.exe to Parse only while I am running from the command promt ('DOS' prompt) If i try to load a Perl file from my webserver Like LocalHost\PerlTest.pl my broswer always say file not found? What's up with that...I admit I'm new and probably doing something stupid but please help me anyway.

#2 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 06 May 2006 - 12:29 PM

Make sure the perl file is in W:/cgi-bin, then access it by going to http://localhost/cgi-bin/name.ext

If you place it in the W:/www/, try http://losthost/name.ext, but it might not work sometimes in there... it should definately in the cgi-bin though.

#3 MrX

MrX

    The Mad Theorist

  • Support Team
  • PipPip
  • 167 posts
  • Location:IRC :P
  • Wiki ID: MrX
  • IRC Nickname: MrX, MrX- and MrX_

Posted 23 June 2006 - 08:34 PM

Olajide: shouldn't CGI scripts work in W:\www\ if he is using the default .htaccess, which has
AddHandler cgi-script .pl .cgi
Options +ExecCGI
in them?

On the other hand, the only cgi-script AddHandler in httpd.conf is commented and I don't think it is enabled specifically for cgi-bin as I don't see it in the <Directory> directive for cgi-bin and there is no .htaccess in cgi-bin.

Hmmm.. is this (cgi-bin doesn't have AddHandler cgi-script uncommented by default) a problem that no one has found or am I missing something?

#4 ook

ook

    Newbie

  • Member
  • Pip
  • 2 posts

Posted 01 July 2006 - 08:13 PM

I was wrong once, but I think uncommenting "AddHandler cgi-script .cgi" would work if the default section or the doc root section include an "AllowOverriede All" or "AllowOverride Options" directive.

This config file seems to use more administrative oriented scriptalias directives:

# ScriptAlias: This controls which directories contain server scripts.
# ScriptAliases are essentially the same as Aliases, except that
# documents in the realname directory are treated as applications and
# run by the server when requested rather than as documents sent to the client.
# The same rules about trailing "/" apply to ScriptAlias directives as to
# Alias.

ScriptAlias /cgi-bin/ "/cgi-bin/"

# "C:/Program Files/Apache Group/Apache2/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.

<Directory "/cgi-bin">
  AllowOverride All
  Options ExecCGI
</Directory>

<Directory "/home/admin/www/cgi-bin">
  AllowOverride All
  Options ExecCGI
</Directory>


#5 MrX

MrX

    The Mad Theorist

  • Support Team
  • PipPip
  • 167 posts
  • Location:IRC :P
  • Wiki ID: MrX
  • IRC Nickname: MrX, MrX- and MrX_

Posted 02 July 2006 - 01:47 AM

Ok, sorry for all that nonsense.
I take back what I said.

Now I know that "ScriptAlias" does the same thing as "AddHandler cgi-script .pl .cgi", thanks for telling me :)

#6 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 09 July 2006 - 04:53 PM

:( :D :) :D :mellow: :angry:: :angry: :angry: :angry: and a :angry:




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users