Jump to content


Photo

Uniform Server Zero XI on Windows server not restarting


  • Please log in to reply
5 replies to this topic

#1 stephen_r_miles

stephen_r_miles

    Newbie

  • Member
  • Pip
  • 2 posts
  • Main OS: Windows 7

Posted 18 September 2014 - 03:27 PM

I have setup Uniform Server Zero XI on a windows server to run an online application 24/7. Each time the server restarts I have to login for Uniform Server to start.

Once login happens it automatically start but I would like it to start without having to login.

Does anybody have any solutions for this?

Thank you

#2 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 24 September 2014 - 09:46 AM

You can try the following to see if that helps:

First check the services are set to automatic if not change them accordingly.

If they are set to automatic. In an elevated command prompt type the following:
sc config us_apache_1 start=delayed-auto
sc config uus_mysql_1 start=delayed-auto

Other than that I have no idea.

All the best
Ric



#3 stephen_r_miles

stephen_r_miles

    Newbie

  • Member
  • Pip
  • 2 posts
  • Main OS: Windows 7

Posted 16 October 2014 - 08:43 AM

Thank you for your response, sorry for the delay I have been working on other projects.

 

I will try these and get back to you.  

 

Do I type them into the command prompt when I am in the same directory as UniController.exe?



#4 curiouscrow

curiouscrow

    Newbie

  • Member
  • Pip
  • 1 posts
  • Main OS: Other

Posted 12 December 2014 - 01:30 PM

I'm having the same issue (I think). I need Apache to start when the server starts with out having to log on.

I'm running UniServer XI 11.4.1 on Win Server 2008 R2.

I've tried starting the UniController as administrator and in compatibility mode (XP).

The PC-Win Start up only starts when we log in.

 

I tried (running command as administrator):

sc config us_apache_1 start=delayed-auto
sc config uus_mysql_1 start=delayed-auto

But the response is as if it did not even recognize the service names

 

I also tired:

C:\webroot\core\apache2\bin>httpd_z.exe -k install
Installing the Apache2.4 service
The Apache2.4 service is successfully installed.
Testing httpd.conf....
Errors reported here must be corrected before the service can be started.
[Fri Dec 12 12:10:15.732486 2014] [core:warn] [pid 1192:tid 280] AH00111: Config
 variable ${US_ROOTF} is not defined
httpd_z.exe: Syntax error on line 44 of C:/webroot/core/apache2/conf/httpd.conf:
 ServerRoot must be a valid directory

Has anyone gotten this to start automatically after a reboot?



#5 meows

meows

    Junior Member

  • Member
  • Pip
  • 28 posts
  • SourceForge IDmeows
  • Main OS: Windows XP

Posted 17 January 2015 - 03:48 AM

 

curiouscrow

Has anyone gotten this to start automatically after a reboot?

 

23

the question about starting apache and mysql at boot even before you log in, I have a success story, I figured it out for WIN7 I do not know about WIN8 though. 

 

  I went to start windows help and typed in schedule task and made a advanced task, in win 7 there seems to be 2 types. basic and schedule . Anyway in the First Tab General click the option, at system start up. Then again in  Triggers select at system start up. However this alone does not guarantee apache will fire at boot. you have to go to the general tab again and choose a new user to start apache.. and NETWORK will start any program that uses the NIC at system boot or reboot. Just make sure to add the parameters you need to restart apache -r,

 

 

Now thats cleared up lets move on to the serious stuff that is really making me mad.. since I need SSL and Zero X is short on the information I need,

Errors reported here must be corrected before the service can be started.
[Fri Dec 12 12:10:15.732486 2014] [core:warn] [pid 1192:tid 280] AH00111: Config
 variable ${US_ROOTF} is not defined
httpd_z.exe: Syntax error on line 44 of C:/webroot/core/apache2/conf/httpd.conf:
 ServerRoot must be a valid directory

 

Since I installed a certificate i get the same errors you are getting.. and search as I may I can't re-find the one post I saw years ago about the dam ${US_ROOT] crap. I say it's crap as it's a variable but a variable I can't find a way to change to what I need. Before the certificate I just loaded every file in the UniServerZ22 directory into Notepad++ and did a replace all opened files ${US_ROOT] to c:/UniServerZ22 and everything worked,.

 

Now nothing will even start, no matter what I do. So I can't run ssl at all. SO here comes c:/UniServerZ23 so I can at least get a web site up. If any one knows how to harness ${US_ROOT] ${US_ROOTW and ${US_ROOT]SSL either how to re direct them or better yet how to remove them I would love it. I can't run mysql until i have some security in place for it. as for some reason everytime i start MySql my port watcher security shows china and the Ukraine is banging at my doors.



#6 meows

meows

    Junior Member

  • Member
  • Pip
  • 28 posts
  • SourceForge IDmeows
  • Main OS: Windows XP

Posted 18 January 2015 - 05:17 AM

26

wow what a trip'' I ran a new install of X and it went seamlessly. but prior i went into the registry and deleted every uniform server referance there was. Gosh the variables are working@!  Getting excited again. going to go for the ssl. if it works I will report back on what I did so maybe it will help others,

 

PS loaded the works. perl pear and so on.. I did put a lock on UniserverZ\home\us_opt1 and the other home directories by using a htpassword for each dir.. keeps everyone out. and the files work fine.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users