Jump to content


Photo

Outside Access


  • Please log in to reply
104 replies to this topic

#1 AoN

AoN

    Member

  • Member
  • PipPip
  • 95 posts
  • IRC Nickname: AngelOfHell

Posted 26 April 2006 - 11:50 PM

I know there are severa; threads already made to cover this, but, they all seem to be for another verson of UniServer, I'm not sure on that.

Due to this, I am completly lost on how to get this is working right.

To start out, I am behind a router, I really wish I wasn't, but, I am. :(

The router is a DI-624 from D-Link, and I have full access to the admin site for it.

I have UniServer 3.3, and it is fully installed, not as a server, I use my PC for other things, and as a server, is tend to lag a bit...

I'm registered with DynDNS, and I was hoping to get this working so I can stop paying for hosting for unreliable hosts. ^^'

Thank you in advance for your help.
IPB Image - Hail my own banner for UniServer!

#2 tyrellstapp

tyrellstapp

    Newbie

  • Member
  • Pip
  • 2 posts

Posted 27 April 2006 - 03:18 AM

I cannot get it to work either!

I dont even have a router. Im connected direct and still having difficulties.
Everything works great LOCALLY, but when I try to access from outside via internet - NOTHING. Ive allowed port 80, restarted server, edited HTACCESS to allow ALL, restarted server - STILL NOTHING.

I dont think its the router - GOOD LUCK

#3 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,351 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 27 April 2006 - 08:05 AM

Please, dont come to other peoples post posting something like this. You only had a problem and now you are bring others down. You didn't check to see if it is your router or if something else might be using the port like Skype. The problem is not with Uniform Server as it works for a lot of people, so please check your PC and your router setting.

About your problem AoN, first you have to do a port forwarding in your router. you have to forward port 80 to your PC's local address. After that, make sure that all firewall is set to allow connections to port 80.

About DynDNS, i will have to get back to you on taht one cause i never really tried them, but there is a post on how to set it up with the Uniform Server and it should work for all versions since it deals with DynDNS aspect and not the version of Uniform Server.

Try using that post and if you need help just reply here and i will try to help you as best i can. I am trying to find an alternative i heard of, but till then please hold on.

:(

#4 AoN

AoN

    Member

  • Member
  • PipPip
  • 95 posts
  • IRC Nickname: AngelOfHell

Posted 27 April 2006 - 03:15 PM

My computers IP address would be 192.168.0.100, and I have set it to forward port 80.

Then there's the firewall, I don't know if I have one.
IPB Image - Hail my own banner for UniServer!

#5 kalpz

kalpz

    Beta Team Member

  • Beta Tester
  • PipPip
  • 132 posts
  • Location:New Zealand
  • IRC Nickname: LifeSteala
  • Main OS: Windows Vista

Posted 30 April 2006 - 02:08 AM

Just to let you all know, you cannot view an external domain on your network. If you are trying to view your page by some DynDNS url, it wont work. But, if you gave that URL to a friend who doesnt live at your place, it will work. Providing everything else is set up properly.


If your still having problems, Tell me and I will help. (I finally got mine working after a yr and a half.. Hahaha).
ATOMIC Web Hosting 2007 - 2011
Shared Hosting - Reseller Hosting - Dedicated Servers - Virtual Private Servers (Request Dedicated/VPS Servers via E-mail)
E-mail: sales@atomicwebhosting.com Website: http://www.atomicwebhosting.com/

#6 AoN

AoN

    Member

  • Member
  • PipPip
  • 95 posts
  • IRC Nickname: AngelOfHell

Posted 30 April 2006 - 05:26 PM

Everyone says they can't access it via DynDNS or the direct IP address. So, I think I screwed up somewhere. :(

http://esbrandt.does.../Brutal_Knights

That's the DynDNS hyperlink, and I'm not to comfortable with posting my IP address, because the admins can easily get that from logs.
IPB Image - Hail my own banner for UniServer!

#7 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,351 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 30 April 2006 - 06:36 PM

I was about to tell you that the IP you gave on your last post was not a real IP but a network IP.

So what is the problem now... is everything ok :(

If you have a firewall, try and shut it down just to test and then enter the setting to change the setting to not block port 80.

Make sure that you set the router forwarding correctly.

#8 AoN

AoN

    Member

  • Member
  • PipPip
  • 95 posts
  • IRC Nickname: AngelOfHell

Posted 30 April 2006 - 07:36 PM

I think I set the forwarding correctly. As for the firewall, the only firewalls that I can think of would be the router firewall, which I have told t to allow port 80 by default of UniServer (It automaticly put it in there...), and the Microsoft Windows Firewall, which I have set port 80 for both TCP and UDP.

I just disabled my firewall on Windows, and it didn't work, and I can't disable the router firewall. :(
IPB Image - Hail my own banner for UniServer!

#9 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,351 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 30 April 2006 - 07:46 PM

hmm.. only other thing is that your ISP is blocking port 80. Try changing the port to port 81 and test it.

You can do this by changing Listen 80 to Listen 81 in the httpd.conf file in W:/usr/local/apache2/conf folder.

#10 AoN

AoN

    Member

  • Member
  • PipPip
  • 95 posts
  • IRC Nickname: AngelOfHell

Posted 30 April 2006 - 07:58 PM

Do I have to change the port forwarding on my router admin site?
IPB Image - Hail my own banner for UniServer!

#11 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,351 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 30 April 2006 - 08:01 PM

Yes.

#12 AoN

AoN

    Member

  • Member
  • PipPip
  • 95 posts
  • IRC Nickname: AngelOfHell

Posted 30 April 2006 - 08:06 PM

I have edited the ports, and all, I restarted the server, and my friends still can't access it.

I know it isn't because they are on the same network or ISP, as they live on the other side of the world...

:(
IPB Image - Hail my own banner for UniServer!

#13 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,351 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 30 April 2006 - 08:48 PM

Yap, your ISP is blocking port 80.

Its working.

Here it is.

http://70.160.214.143:81/news.php

Sorry if your ip is shown but it really makes no differnce as youo can se it also via the link. When it gives an error or on the progress bar of IE and FF.

Also by viewing the source of the page

#14 AoN

AoN

    Member

  • Member
  • PipPip
  • 95 posts
  • IRC Nickname: AngelOfHell

Posted 30 April 2006 - 08:51 PM

How would I set up the A record of an outside domain to goto that?
IPB Image - Hail my own banner for UniServer!

#15 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,351 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 30 April 2006 - 08:54 PM

Probably set the www to your IP.

#16 AoN

AoN

    Member

  • Member
  • PipPip
  • 95 posts
  • IRC Nickname: AngelOfHell

Posted 30 April 2006 - 09:23 PM

I meant with the port.

Also, now I can't log into my test site.

http://esbrandt.does.../Brutal_Knights

I fixed the port on DynDNS, so, now it will load, but I still can't login.

User: AoN
Pass: admin
IPB Image - Hail my own banner for UniServer!

#17 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,351 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 30 April 2006 - 09:52 PM

You will have to add :81 to the end of the ip. Like i did in the post.

#18 AoN

AoN

    Member

  • Member
  • PipPip
  • 95 posts
  • IRC Nickname: AngelOfHell

Posted 30 April 2006 - 10:00 PM

nvm, I fixed it. ^^'

It was in my site config file.

*feels really stupid for having overlooked it*
IPB Image - Hail my own banner for UniServer!

#19 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,351 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 30 April 2006 - 10:43 PM

:(

#20 AoN

AoN

    Member

  • Member
  • PipPip
  • 95 posts
  • IRC Nickname: AngelOfHell

Posted 30 April 2006 - 10:50 PM

I'm told that the port wasn't permitted in the A Record. :(
IPB Image - Hail my own banner for UniServer!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users