Jump to content


Photo

How to install the ImageMagick extension with Uniform Server ZeroXI (WAMP))

imagick imagemagick plugin plug-in wordpress

  • Please log in to reply
1 reply to this topic

#1 Luke Wolf

Luke Wolf

    Newbie

  • Member
  • Pip
  • 3 posts
  • Main OS: Windows 7

Posted 09 July 2014 - 04:41 AM

I searched online for an hour to no avail and then spent a couple of hours figuring out how to install the ImageMagick extension on a Windows system with Uniform Server ZeroXI.  The following may save some time and frustration for others wanting to use this utility with their local PHP site. I'm using it for local WordPress development.

 

In this case, the installation is on a Windows 7 (64-bit) box.
However, in this example, the 32-bit version is installed for testing.

For the installation steps below, PHP 5.5 has been installed.
Use the provided note (minor change) for other versions of PHP.


Optional Windows Stand-alone installation:

1.    The stand-alone version of ImageMagick for Windows is here:
        http://www.imagemagi...ses.php#windows
2.    Download/install either:
        ImageMagick-6.8.9-5-Q8-x64-dll.exe or ImageMagick-6.8.9-5-Q16-x86-dll.exe.
3.    Be sure to click on the "Add to system path" checkbox.
4.    Test/use the application from start menu application or the desktop icon.
5.    Command line examples are here:
        http://www.imagemagick.org/Usage/


Uniform Server ZeroXI ImageMagick installation:

1. from here:
        http://pecl.php.net/...k/3.1.2/windows
2. download:
        '5.5 Thread Safe (TS) x86'
3. unzip:
        php_imagick-3.1.2-5.5-ts-vc11-x86.zip
4. copy:
        CORE_RL_bzlib_.dll
        CORE_RL_glib_.dll
        CORE_RL_lcms_.dll
        CORE_RL_lqr_.dll
        CORE_RL_magick_.dll
        CORE_RL_ttf_.dll
        CORE_RL_wand_.dll
        CORE_RL_zlib_.dll

5. to:    YOUR_LOCAL_PATH\UniServerZ\core\php55
        (use the php54 folder, if you don't have PHP 5.5 intalled)
6. copy:
        php_imagick.dll
7. to: YOUR_LOCAL_PATH\UniServerZ\core\php55\extensions
        (use the php54 folder, if you don't have PHP 5.5 intalled)
8. with the UniController, Stop Apache
9. from the UniController menu, choose: PHP -> Edit selected configuration file
10. locate the 'Dynamic Extensions' section
11. insert (on a line by itself and press Enter):
        extension=php_imagick.dll
12. save and close the configuration file
13. with the UniController, Start Apache
14. the PHP ImageMagick manual is here:
        http://www.php.net/m...ook.imagick.php
15. verify successful implementation with phpinfo(), search for 'imagick module'
        (from the UniController menu, choose: PHP -> View phpInfo)
16. or, verify with the following PHP function:

function get_imagick_version()
{
    // the API version number will be returned (currently 6.8.8), or 0 on failure
    // the module version number is a different value (currently 3.1.2)

    $imagick_v = 0;

    if (extension_loaded('imagick') && class_exists('Imagick'))
    {
        $imagick = new Imagick();
        $imagick_info = $imagick->getVersion();

        $imagick_vs = $imagick_info['versionString'];
        preg_match('/ImageMagick ([\d]*\.[\d]*\.[\d]*)/', $imagick_vs, $imagick_vs_return);
        $imagick_v = $imagick_vs_return[1];
    }

    return $imagick_v;
}


#2 Cigaras

Cigaras

    Newbie

  • Member
  • Pip
  • 7 posts
  • Gender:Male
  • Main OS: Other

Posted 09 September 2016 - 05:40 AM

Thank You for sharing Your experience.

 

I tried following this guide for ZeroXII using php 7.0 and it did not work, copied CORE_*.dll files to Apache bin folder and imagic appeared on on phpinfo() but did not recognize any formats, fixed that by downloading more dll's from http://windows.php.n...loads/pecl/deps/ to into Apache bin folder using information found on http://lt1.php.net/m...etup.php#119083.







Also tagged with one or more of these keywords: imagick, imagemagick, plugin, plug-in, wordpress

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users