Jump to content


thersander

Member Since 31 Mar 2019
Offline Last Active Apr 01 2019 01:15 PM
-----

Topics I've Started

MySQL Innodb file locations ignored by XIII UniController

31 March 2019 - 04:57 PM

I am having a problem with the command line options that the XIII UniController provides when it launches the MySQL server.
 
I run a handful of Uniform Servers in parallel - mainly Coral 8.x.x servers and 1 XIII server. I have recently switched from a Windows 7 Pro (32-bit) laptop to a 64-bit laptop running Ubuntu, and Windows 7 Pro as a VirtualBox VM. The latter 2 OSes are both 64-bit versions.
 
For my MySQL databases, I have them centrally located in a file structure consisting of a single main directory with a sub-folder for each US server. Each sub-folder contains all of the MySQL databases used by that US server. As part of the laptop/OS change I have simply copied this file structure and files from my old SSD to the K: drive of my new SSD.
Attached File  Screenshot - 2019-03-31, 14_08_10_ver001.png   40.99KB   0 downloads
 
In order to ensure each server accesses the correct database(s), in the my.ini file for each MySQL server I have defined the location of the database files, using the following directives:
basedir
datadir
tmpdir
innodb_data_home_dir
innodb_log_group_home_dir
 
Each server also uses its own unique pair of port numbers for the Apache and MySQL servers.
 
I am trying to run the XIII server which I have called zero_xiii_sv0, the database files for which are located in the directory K:\WebServerFiles\MySQL_dbs\zero_xiii_sv0\data.
 
The directory K:\WebServers contains a number of sub-folders, with each sub-folder containing a single installation of a US.
The directory K:\WebServers\zero_xiii_sv0\UniServerZ\data is the default location for the database files created when the XIII server is installed.
 
The MySQL server my.ini file contains the following entries regarding file locations:
datadir = "K:/WebServerFiles/MySQL_dbs/zero_xiii_sv0/data/"
innodb_data_home_dir = "K:/WebServerFiles/MySQL_dbs/zero_xiii_sv0/data/"
innodb_log_group_home_dir = "K:/WebServerFiles/MySQL_dbs/zero_xiii_sv0/data/"
 
When the UniController is used to launch the MySQL server, the server is started using the following command string:
K:\WebServers\zero_xiii_sv0\UniServerZ\core\mysql\bin\mysqld_z0.exe 
--defaults-file = "K:\WebServers\zero_xiii_sv0\UniServerZ\core\mysql\my.ini" 
--tmpdir = "K:\WebServers\zero_xiii_sv0\UniServerZ\tmp" 
--datadir = "K:\WebServers\zero_xiii_sv0\UniServerZ\core\mysql\data" 
--innodb_data_home_dir = "K:\WebServers\zero_xiii_sv0\UniServerZ\core\mysql\data" 
--innodb_log_group_home_dir = "K:\WebServers\zero_xiii_sv0\UniServerZ\core\mysql\data"
and I am unable to connect to the (ttrssdb) database.
 
As can be seen from the command string, the values of the data items:
datadir
innodb_data_home_dir
innodb_log_group_home_dir
are incorrect.
 
They should instead reference the databases in 
K:\WebServerFiles\MySQL_dbs\zero_xiii_sv0\data
instead of the default location of
K:\WebServers\zero_xiii_sv0\UniServerZ\core\mysql\data
 
I have tried running in a DOS session the Apache server with the correct command line string and that worked successfully, allowing me to attach to the correct database.
 
Am I missing something in the server configuration or is the procedure invoked by the "Start MySQL" button of the UniController simply ignoring the values provided in the my.ini file?
 

Unable to run Coral Uniform Servers on Windows 7 Pro x64 VirtualBox VM

31 March 2019 - 04:30 PM

I have recently changed my ancient 32-bit Windows 7 Pro laptop for a 64-bit replacement, and have chosen to run 64-bit versions of Ubuntu as the main OS with Windows 7 Pro as a VirtualBox VM, instead of running Windows 10 which came pre-installed.
 
On my old laptop, I ran a handful of Uniform Servers in parallel - mainly Coral 8.x.x servers. The file structure I used for the servers on the old laptop has been duplicated on the new SSD running the Windows 64-bit VM. I have therefore been able to copy as-is the old server file structure to the new SSD.
 
The Uniform Server I am trying to start is an 8.6.7/Coral version, but I am encountering the same problem with all of the other Uniform Servers I have installed (all of which are 8.x.x versions).
 
I have also installed the 2008 C++ redistributable as described here.
 
I tried separately with the 32-bit then the 64-bit redistributable, and with both installed.
 
However, I am unable to start either the Apache http or MySQL servers, using run-as-a-program or run-as-a-service. The message which is displayed in a dialog box is "Unable to start Apache server":
 Attached File  Screenshot - 2019-03-31, 17_51_00.png   14.8KB   0 downloads 
 
I have investigated starting the Apache server further using Procmon (from Sysinternals), and the correct http.exe appears to be located, but the server never attempts to launch. There are no diagnostics in the Apache logs or the Windows event logs. The same problem is encountered when trying to launch the MySQL server too.
 
Given that the old and new file structures are identical, and that the US servers ran successfully on the old structures, I can only conclude that something in the new underlying OS configuration may be responsible.
 
Can anyone suggest what the underlying issue may be, or suggest any other additional diagnostics which might help to pinpoint the underlying issue?
 
I am able to successfully run a XIII Uniform Server, and was planning to migrate from Coral to XIII. However, I am having a separate problem in running the XIII server for which I will raise a separate forum entry, so that option is not really a solution to my immediate problem.