Jump to content


Photo

Switch Problem. :@


  • Please log in to reply
2 replies to this topic

#1 GodsDead

GodsDead

    Newbie

  • Member
  • Pip
  • 5 posts
  • Location:Essex - Clacton.
  • Interests:Skateboarding, music! :P

Posted 03 April 2006 - 12:32 PM

Well heres the thing, im not sure why this isnt wokign as it seems fine, adn works on other servers, maybe somehtings happedned in apache.. heres the code im trying to work:
(index.php)
<?php

switch($load){
case"":
echo"Index";
break;

case"about":
echo"About my Sexy ass.";
break;

default;
echo"page not found loser";
break;
}
?>
Pointing your browser to index.php?load=about

I still get "index" echoed, and i keep trying arraangements of this code, and there is no reason why it shuld work, It used to work fine..
Any ideas why this isnt working?
And i have tryed different directorys and fiddleign the code..

#2 matrey

matrey

    Translation Team Member

  • Translator
  • Pip
  • 1 posts
  • Location:Grenoble, France
  • SourceForge IDmatrey

Posted 06 April 2006 - 02:38 AM

Do you tried to use $_GET[load] instead of $load ?

#3 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,348 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 13 April 2006 - 12:48 PM

Thats because Register Globals is Off.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users