Jump to content


Photo

Activating php_soap.dll


  • Please log in to reply
6 replies to this topic

#1 Ollie222

Ollie222

    Junior Member

  • Member
  • Pip
  • 15 posts
  • Main OS: Windows Vista

Posted 31 August 2010 - 07:56 AM

I'm running Uniformserver 5.5 on windows 7 and I'm trying to switch on php soap.

Am I right in thinking that all I should have to do is copy the php_soap.dll file into the php\extensions folder and then uncomment the following line in php.ini?

extension=php_soap.dll

Am I missing anything else as I've done the above and it's not being recognised.

Cheers

Stu

#2 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 31 August 2010 - 03:30 PM

I'm running Uniformserver 5.5

What you are doing looks fine!
However I will need to dig that version out to see if there where any dependencies.

All the best
Ric :)

#3 Ollie222

Ollie222

    Junior Member

  • Member
  • Pip
  • 15 posts
  • Main OS: Windows Vista

Posted 01 September 2010 - 05:00 AM

I've actually sorted this now, it was my mistake as I was using a VC9 compiled version instead of a VC6 and the errors were being suppressed so I didn't realise this was the problem.

It all looks to be working now so that's good.

#4 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 01 September 2010 - 03:59 PM

I checked and there were no dependencies.

Thanks for posting; glad you have resolved this issue.

All the best
Ric :)

#5 Boyd

Boyd

    Newbie

  • Member
  • Pip
  • 1 posts
  • Main OS: Windows Vista

Posted 24 September 2010 - 08:55 AM

Forgive me folks, I'm new to Uniform Server and php. Concept of US is just awesome, love it and it works really well. But, I'm trying to do the same re. soap, I want to test and eval the iTop CMDB system, which requires soap to be enabled.

I did exactly the above, copied php_soap.dll into the php\extensions folder, and uncommented the line in the php.ini as described by Ollie222 above.

What I'm not sure of is if there are any version issues. I have just downloaded Nano 5.6.13, and then had to download the whole php 5.3.3. win32 vc6 x86 from windows.php.net to get the php_soap.dll. But there are various versions available there, and I'm not sure which is whch. There is a "thread safe" and a "non thread safe" version. I'm not sure if it makes any difference to the php_soap.dll that comes with the packages. Regardless, the iTop installation pre-check still complains about soap. Unfortunately, php.net is not very useful in this regard.

Thanx and regards

EDIT: PS Sorry, forgot to mention, using Win7

#6 BugFixed

BugFixed

    Newbie

  • Member
  • Pip
  • 6 posts
  • Main OS: Windows Vista

Posted 25 September 2010 - 05:52 AM

You need to use the same version, f.i, use php_soap version 5.2 for PHP version 5.2.x and php sorap version 5.3 for PHP version 5.3.x

#7 monsieur martin

monsieur martin

    Newbie

  • Member
  • Pip
  • 1 posts
  • Main OS: Windows XP

Posted 21 April 2011 - 02:50 PM

The dll's are now in the new packages but they still don't show as activated into the phpinfo() there is no soap section




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users