Jump to content


Photo

Apache, httpd_Z service stops working


  • Please log in to reply
2 replies to this topic

#1 amvjedi

amvjedi

    Newbie

  • Member
  • Pip
  • 2 posts
  • Main OS: Other

Posted 19 January 2015 - 11:43 AM

We are currently running UniServer Zero XI 11.3.3 on Windows 2008 Server Standard.  I had the previous version running and thought that is why the Apache would always stop working.  So I upgraded and I am still having the same issue.  The service stops randomly and inconsistently.  We use this to run Moodle for the students to access their courses.  I tried to install the Service Protector program, but that doesn't work either, because it doesn't see the httpd_z service in the list.  I have attached the error I always get, if I hit the Close the Program button, it goes right back up.  It is very hard to find out when this error is happening, usually it comes from complaints that the site is down :-(. Any help with this would be appreciated.  We have been having the same issue for about 6 months now.

 

Thanks, Angel

Attached Files



#2 meows

meows

    Junior Member

  • Member
  • Pip
  • 28 posts
  • SourceForge IDmeows
  • Main OS: Windows XP

Posted 20 January 2015 - 01:31 AM

50

Where are the error logs? access logs? PHP logs?

 

set httpd.conf = LogLevel debug

 

edit php_development.ini

php_production.ini

set all to E_ALL

; display_startup_errors
;   Default Value: Off
   Development Value: On
;   Production Value: Off

; error_reporting
;   Default Value: E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED
  Development Value: E_ALL
;   Production Value: E_ALL & ~E_DEPRECATED & ~E_STRICT

; html_errors
;   Default Value: On
   Development Value: On
;   Production value: On

; log_errors
;   Default Value: Off
   Development Value: On
;   Production Value: On

 

This should give you the reason for the issues



#3 amvjedi

amvjedi

    Newbie

  • Member
  • Pip
  • 2 posts
  • Main OS: Other

Posted 22 January 2015 - 01:15 PM

Thank you!! I will turn the debugging on and try!! - Thanks, Angel






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users