Jump to content


Photo

BUG: Missing icuuc46.dll and friends for php_intl.dll


  • Please log in to reply
3 replies to this topic

#1 BUGHUNTER

BUGHUNTER

    Newbie

  • Member
  • Pip
  • 4 posts
  • Main OS: Windows XP

Posted 16 September 2011 - 04:23 PM

Hi,

php_intl.dll is required by some major php web apps like wikipedia or moodle - if activated within Uniserver it is missing the needed dlls - you can find the dlls here:
http://sourceforge.n...es/ICU4C/4.6.1/

however they are all compiled with VC10, what might cause other problems - maybe it would be good to compile it all with VC9.

BTW - there is another distribution of apache for windows with php etc. - maybe you know it :) - they have it working, but the dlls are on a wrong path:
http://www.apachefri...php?f=4&t=44405

these also seem to be VC9 compiled icu*.dll files - might be helpful...


Thanks for your attention!
Bughunter

#2 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 17 September 2011 - 04:05 AM

You describe this as a showstopper. If this were the case I would have expected to see more request for this to be included.

Reason for not including is the hit on footprint size. That said if more users state a requirement for its inclusion will be added.

All the best
Ric :)

#3 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 24 September 2011 - 02:50 PM

UniServer 8.0.B3-Coral beta release fully supports intl

Check out folder UniServer\wiki_material\quick_install_guides
Covers installing Moodle 2.1.1 ;)

All the best
Ric :)

#4 lolo0707

lolo0707

    Newbie

  • Member
  • Pip
  • 1 posts
  • Main OS: Windows 7

Posted 28 September 2012 - 08:38 AM

Hello,
I'm having the same problem with the icuuc46.dll, the system says that it is missing
I have php_intl.dll activated too


EDIT: The problem is when Xampp execute xampp/apache/bin/httpd.exe, while starting the Apache Server
I have copied the icuuc46.dll and all the .dll files (after the icuuc46, it asked for icudt46.dll) from the root folder of Xamp to xampp/apache/bin/ and now it works




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users