Jump to content


Photo

Unable to perform clean shutdown - MySQL after bind-address = ::1


  • Please log in to reply
2 replies to this topic

#1 hedgehog90

hedgehog90

    Newbie

  • Member
  • Pip
  • 2 posts
  • Main OS: Other

Posted 18 September 2015 - 01:39 PM

My $_SERVER["REMOTE_ADDR"] = ::1, unless I change the bind-address in my.ini to match it, when I connect to my database (with PDO) with the hostname 'localhost' it takes ~2 seconds.

When I change bind-address to '::1' or '::', the time to connect with mysql becomes negligible.

However, when I try to 'stop MySQL', it hangs and eventually I get this error and I have to kill the process.

 

It appears my.ini doesn't handle ipv6 addresses well. Is there any way to fix this? if not, please fix this in a later build.

 

I loves this software, I've struggled with XAMPP and WAMP in the past, but this is far superior IMO.



#2 hedgehog90

hedgehog90

    Newbie

  • Member
  • Pip
  • 2 posts
  • Main OS: Other

Posted 19 September 2015 - 06:15 AM

I just realised phpMyAdmin returns this error:

 

MySQL said:
Cannot connect: invalid settings. 
 
When I have bind-address = ::1 in my.ini
 
Please help!!!


#3 Neophitus

Neophitus

    Junior Member

  • Member
  • Pip
  • 11 posts
  • Main OS: Windows 7

Posted 28 September 2015 - 07:45 AM

Have you tried just comment out the line?






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users