Jump to content


Ric

Member Since 30 Apr 2006
Offline Last Active Sep 04 2017 02:05 AM
*****

Posts I've Made

In Topic: Where are the php plugins?

06 February 2017 - 06:49 AM

Uniform Server ZeroXIII modules (Plugins)
 

All the best

Ric


In Topic: phpMyAdmin throws error and doesn't start

06 August 2016 - 06:40 AM

I have traced this issue to the MySQL server.

The error is caused by a missing folder UniServerZ\core\mysql\share\spanish.

As of today (6-8-2016) there were only a few downloads of the new release and its corresponding modules because of this I decided to republish instead of creating new releases:

 

Republished:

13_0_1_ZeroXIII.exe

ZeroXIII_mysql_5_6_32.exe

ZeroXIII_mysql_5_5_51.exe

ZeroXIII_mariadb_10_0_26.exe

ZeroXIII_mariadb_5_5_50.exe

 

All the best

Ric


In Topic: Upgrading to UniServer Zero 12.2.0 -- Problems

11 March 2016 - 05:11 AM

1) "Or do I simply modify one of those three files as needed, leave it in its current directory, and then use the UniController to select the chosen .ini file? " This is correct.

 

Although “Configuration File (php.ini) Path" shows C:\WINDOWS this path is ignored even if it contains a php.ini file. The configuration file loaded is that selected by UniController, on start-up PHP is forced to load only this file.

The php info “Loaded Configuration File” is the one that php is currently using.

 

2) “And I see the file name of the various earlier versions of PHP (e.g., ZeroXII_php_5_6_x.exe).  But nowhere do I see a link to download the needed file(s). ”

 

Not sure I fully understand the problem!

The needed files are contained in self-extracting archives for example ZeroXII_php_5_6_19_g.exe

Download this file from the modules folder https://sourceforge....ZeroXIImodules/

Copy the downloaded file to folder UniServerZ.

Stop servers and close UniController if running, double click downloaded file in folder UniServerZ.

This extracts all required files for php 5.6.19.

Start UniController and select php version php56 this switches to php 5.6.19

You are now ready to run the servers.

 

All the best

Ric


In Topic: UniServer Zero XII Missing FTP Support?

19 February 2016 - 07:22 AM

Zauberlehrling!:

It looks like the offical release wants to use mysql.dll this is not contained in PHP 7.0.x

The v2.x Developers version of e107 resolves this issue. Download from:

https://github.com/e...hive/master.zip

The above installs on a default installation of Uniform Server Uniform Server 12.1.0-ZeroXII

All the best
Ric


In Topic: UniServer Zero XII Missing FTP Support?

19 February 2016 - 07:21 AM

JaggedJax:

There is ftp support, to enable this add the following line:

extension=php_ftp.dll


to the php configuration files:

php_development.ini, php_production.ini and php_test.ini

All the best
Ric