Jump to content


Photo

Not welcome to phpMyAdmin...


  • Please log in to reply
10 replies to this topic

#1 bavel

bavel

    Newbie

  • Member
  • Pip
  • 1 posts

Posted 29 March 2005 - 09:16 AM

When I try to access phpMyAdmin from the administrator screen, I do not get a chance to enter a username and password - instead I get an error message:
MySQL said: "#1045 - Access denied for user: 'root@localhost' (Using password: YES)"

Exactly where can I change the password to re-enable the login?

#2 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 29 March 2005 - 11:48 AM

The server is not running and that is why you get that message. The MySQL server is not running.

You do not need to chnage the password because it automatically uses the admin password.

Start the MySQL server and it should work. If you are still intrested in changing the password, edit the mysql_password file. Chnage the value to the password you want and that will be the new root password for MySQL.

#3 pHiLix

pHiLix

    Newbie

  • Member
  • Pip
  • 3 posts
  • Location:Australia, Melbourne

Posted 18 May 2005 - 10:52 PM

I get an error message:
MySQL said: "#1045 - Access denied for user: 'root@localhost' (Using password: YES)"

i have this exact same problem as well. i clicked on "run MySQL Server" first then clicked on "PhpMyAdmin" and it still gives me this error.

but when i try to stop the MySQL server, it says that the server was not running so that means it was never running at the start even though i clicked on "run MySQL Server"?

what is going on here? is there anything else i forgot to install? because i just download uniserver 3.2 and ran it, nothing else.

i really need some help to get PhpMyAdmin running, its for an assignment i have to do B)

thanks in advance guys.

#4 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 18 May 2005 - 11:27 PM

Did u chnage the phpMyAdmin password or the MySQL root password by any chance?

Or are u using a new downloaded copy of phpMyAdmin and is MySQL installed on your computer 2ce?

#5 pHiLix

pHiLix

    Newbie

  • Member
  • Pip
  • 3 posts
  • Location:Australia, Melbourne

Posted 19 May 2005 - 02:31 AM

Did u chnage the phpMyAdmin password or the MySQL root password by any chance?

Or are u using a new downloaded copy of phpMyAdmin and is MySQL installed on your computer 2ce?

nah, i havent changed any passwords.

my copy of phpMyAdmin is old, its the version that came with Uniserver 3.2 i think. i will download the latest version and see how it goes.

what MySQL? Uniserver you mean? as i mentioned in my previous post, i only installed "Uniserver 3.2" and nothing else.

#6 pHiLix

pHiLix

    Newbie

  • Member
  • Pip
  • 3 posts
  • Location:Australia, Melbourne

Posted 19 May 2005 - 05:03 AM

got it working B)

installed the latest version of phpMyAdmin, version 2.6.2 and it worked.

thanks for the help olajideolaolorun :D

#7 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 19 May 2005 - 06:27 AM

No problem, but i am still confused as to why the phpMyAdmin that came with the server did not work for you..

#8 phim

phim

    Newbie

  • Member
  • Pip
  • 1 posts

Posted 04 July 2005 - 04:09 PM

No problem, but i am still confused as to why the phpMyAdmin that came with the server did not work for you..

View Post


Yeah, it happend to me too.

I was on Uniformserver3.0 with NO root password, so my 12 databases (32Mo) in diskw\usr\local\mysql\data were configured to work with root/"" (no password).
So when I installed Uniformserver3.2a, all my databases didn't work anymore.

Ok, ok, I hear you, "just add it in your config", right but I have 147Mo in my /www folder ! (31 projects) so noway to change it.

So, smart as I am, I changed privileges settings for root to "NO password",
Then messed up with phpmyadmin (which log as root with password "root" (root/root)) and get the error message above in the first post.

Finally, I red your post and found where the password was in : \diskw\home\admin\WWW\mysql_password

so first I changed the root password in privileges to No password THEN deleted "root" in mysql_password and save and it works fine (it logs without password like old versions).

Something I'd like to add :
I use uniformserver since version 2.something.
When you have various project (like I do) in /www, the easiest way to upgrade is to replace every old folders by new ones except /mysql/data/"data_projects" folders and diskw/www, but it's a little bit tricky if some other stuff changes too.
May be if mysql data folders could be rerouted to somewhere else ?? outside /usr ??

Good luck and thanks for this great tool!

Phil

#9 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 04 July 2005 - 04:22 PM

We will work on an upgrade tool or installer :( but about the mysql data, sorry... thats the best place... and it fits :D so things don't get messy

#10 Mindez

Mindez

    Newbie

  • Member
  • Pip
  • 9 posts

Posted 28 August 2005 - 01:13 AM

Erm... I got the same error.

With phpMyAdmin 2.6.0-beta2:

MySQL said: Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: NO)

With phpMyAdmin 2.6.3-pl1:

MySQL said: Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: NO)

With phpMyAdmin 2.6.3-rc1:

MySQL said: Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: YES)


It was working perfectly before I upgraded Uniform...

#11 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 28 August 2005 - 05:02 PM

Is the /home/admin/WWW/mysql_password file still there?

If it isn't, create a file anmed mysql_password, no extension and enter root as the password. :(

Hope this helps...




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users