Jump to content


Member Since 28 Nov 2014
Offline Last Active Dec 01 2014 12:53 AM

Posts I've Made

In Topic: Basic Apache Configuration

01 December 2014 - 12:54 AM

Ok I found the problem was apparently my browsers needed the cache's flushed.

The program is presently running and I am external and locally able to communicate through it.

Thanks for everything.



In Topic: Basic Apache Configuration

30 November 2014 - 05:59 PM

I thought I had it licked.  Not sure what happened but I'm getting a sever rejected connection message.  I've reinstalled it several times, don't think I'm missing anything but no luck.  I'm going to have to give up unless you can give me some advice. 


I can get localhost fine but no remote and yes the hosts file does not have a redirect in it. The htaccess files are # out, I just don't understand what is going wrong, it all looks so simple.

In Topic: Basic Apache Configuration

29 November 2014 - 09:37 PM

I see.  If I change the local url to "localhost:81" then I connect locally.  mydomain.com connects remotely from any computer including the local one.

In Topic: Basic Apache Configuration

29 November 2014 - 08:14 PM

Thank you for your help Ric,


I didn't realize that when I changed the Apache config port the program automatically set a line in the hosts file so I deleted the line and it now does allow me to see the page externally.



The basic steps I took are these:

1)  Edit Basic Configuration  

        Server name = "mydomain.com"  also add Server Admin Email

        (Change  Listen port set to 81)


2) Extra Edit Win Hosts File

       Delete the Hosts entry for myDomain.com


3) Access and Passwords

       Password Disabled (for now)

       Set to "Local, Intranet and Internet Access"


>>> start Apache Server <<<

Local page FAILS to resolve

Try URL from a separate remote system (no :81 in url) (SUCCESS! system connects remotely :D :D :D)


Try URL again from local system but remove the :81 from the URL

   SUCCESS! (system connects locally :D :D :D but :81 had to be removed)




Bottom line... and just to be clear, when I stop and restart Apache, on start it automatically brings up (or tries to bring up) the page locally and fails with port 81 automatically attached to the local url UNLESS I remove the :81 from the local (mydomain.com) URL and try again it resolves just fine (I assume)  because it is doing so over the internet though my noip redirect just like any external system would.  This means I can not connect locally unless I change my ip back to 80 for that moment to do so.


I don't think this is a bad thing because I could certainly work around it but I just want to be clear about it. 

Do I have this correct?  


Thank you very much for your courtious help.



P.S. donation coming :)

In Topic: Basic Apache Configuration

29 November 2014 - 02:32 AM

I've looked this over pretty well and I'm fairly sure when you change the apache listen port it should not be appended to the URL above. This has to be an overlooked bug because it makes it pretty much impossible to use a registered domain name that has a port redirect on it unless I've missed some setting somewhere.