Jump to content


Photo

empty folder for phpmyadmin


  • Please log in to reply
8 replies to this topic

#1 mojito

mojito

    Junior Member

  • Member
  • Pip
  • 25 posts

Posted 22 January 2011 - 03:25 PM

Ok so I just 'installed' the latest version and I find that clicking the link to phpmyadmin does nothing.

I then went and looked around a bit not really knowing what im doing. And I find that the etc/phpmyadmin is empty

what do i need to copy here if anything ? my old install has files in here but i would think im not doing this right...

any help greatly appreciated
thanks

edit:ok i found that i cannot access due to issue by browsing http://localhost/apanel/phpMyAdmin/

#1045 - Access denied for user 'root'@'localhost' (using password: YES)
http://www.landed.at - a travel forum, please come along and post something about a destination you know.

#2 mojito

mojito

    Junior Member

  • Member
  • Pip
  • 25 posts

Posted 28 January 2011 - 02:38 AM

All the password files I can find look to be

root:

which is correct why does phpmyadmin think I am using a password ?
http://www.landed.at - a travel forum, please come along and post something about a destination you know.

#3 mojito

mojito

    Junior Member

  • Member
  • Pip
  • 25 posts

Posted 29 January 2011 - 06:02 PM

All the password files I can find look to be

root:

which is correct why does phpmyadmin think I am using a password ?


After a couple of hours I found the files I needed to change, the config file uses php to look inside a text file a folder above.
I was getting then an error which was that I needed to set the flag to allow no password to work.

But I am seeing that I cannot now create a db in phpmyadmin. It gives me a green status message but no db is actually created. Will open a new thread for this. But for me the original issue is solved after a couple of hours however.
http://www.landed.at - a travel forum, please come along and post something about a destination you know.

#4 Shyokou Ouyou

Shyokou Ouyou

    Member

  • Member
  • PipPip
  • 72 posts
  • Main OS: Windows XP

Posted 30 January 2011 - 12:40 AM


It might indicate that something lost during your installation, due to instability of your OS or somewhere in a silent way, if you are sure of key parts intact ...

I would recommend to install into another folder such that you have two copies to compare ...


Ok so I just 'installed' the latest version and I find that clicking the link to phpmyadmin does nothing.

I then went and looked around a bit not really knowing what im doing. And I find that the etc/phpmyadmin is empty

what do i need to copy here if anything ? my old install has files in here but i would think im not doing this right...

any help greatly appreciated
thanks

edit:ok i found that i cannot access due to issue by browsing http://localhost/apanel/phpMyAdmin/

#1045 - Access denied for user 'root'@'localhost' (using password: YES)



#5 mojito

mojito

    Junior Member

  • Member
  • Pip
  • 25 posts

Posted 30 January 2011 - 06:35 AM


It might indicate that something lost during your installation, due to instability of your OS or somewhere in a silent way, if you are sure of key parts intact ...

I would recommend to install into another folder such that you have two copies to compare ...


Well I fixed it using the steps above to know which password to modify.

What I dont understand now is why it doesn't work out of the box, suggests that there is some mysql password that is saved outside of uniserver from some other prior installation.
If anyone knows how I can check for this, but I thought that this would not be the case and that mysql is encapsulated in the package. Or could there be registry issues on passwords.

For the issue of not being able to create a database (also I cant see the default databases !) I am still lost with google not able to help. :) so any ideas appreciated. I am again trying a new instal (but already did in my now mounting discovery of what is the issue.)

ok from a new instal exactly the same issue, the defaults passwords are alll root:root but mysql seems to be set up from elsewhere with root and no password so where is this getting set outside of my UniServer folder ?

This is the issue I seem to be facing and perhaps the reason why even if I edit the default password then its why I cannot create a database.
http://www.landed.at - a travel forum, please come along and post something about a destination you know.

#6 BobS

BobS

    Project Helper

  • Super Moderator
  • PipPipPip
  • 334 posts
  • Location:Santiago Chile
  • Interests:Retiring, computer systems, system design, model railroads....
  • Wiki ID: BobS
  • Main OS: Windows 7

Posted 30 January 2011 - 09:11 AM

This is the issue I seem to be facing and perhaps the reason why even if I edit the default password then its why I cannot create a database.


This sounds like there's a "my.ini" or "my.cnf" file left over from some other WAMP stack. UniServer doesn't do this, but others copy one into \windows. If I recall correctly, MySQL has a search order for the my.cnf-my.ini file that checks this location first.

You might try using a tool I like very much to search everything on your system. It's the Everything search engine: http://www.voidtools.com/ With this you can very quickly find ALL occurrences of my.cnf or my.ini on your system.

Regards,
BobS

#7 mojito

mojito

    Junior Member

  • Member
  • Pip
  • 25 posts

Posted 07 February 2011 - 08:02 AM

Thanks for your advice, I tried that and it worked to find only occurances in the trash and other uniserver folders.

please see image

I am so desperate to work out what isnt working, I feel I need to try another server but I like this one, well when it worked.

What if I copy over the mysql folders ?

Attached Files


http://www.landed.at - a travel forum, please come along and post something about a destination you know.

#8 mojito

mojito

    Junior Member

  • Member
  • Pip
  • 25 posts

Posted 11 February 2011 - 07:08 AM

bump..anyone - or at least let me know if uniserver worked out of the box for you and the link to mysql as well ? I don't want to have to hack the password.


bump..anyone - or at least let me know if uniserver worked out of the box for you and the link to mysql as well ? I don't want to have to hack the password.
http://www.landed.at - a travel forum, please come along and post something about a destination you know.

#9 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 12 February 2011 - 05:38 AM

OK Letís see if we can move this forward!

First gather some diagnostic info:

Download UniServer 5.7.3
Run Run_pre_check.exe ensure ports are free
Start servers
From Apanel change MySQL password
Stop servers

Post log files:
UniServer\usr\local\apache2\logs\error.log
UniServer\usr\local\mysql\data\mysql.err

All the best
Ric :)




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users