Jump to content


Photo

Request-URI Too Large


  • Please log in to reply
7 replies to this topic

#1 rustyp

rustyp

    Member

  • Member
  • PipPip
  • 73 posts
  • Main OS: Windows Vista

Posted 21 January 2014 - 05:46 PM

Hi

I am getting the error

 
Request-URI Too Large

The requested URL's length exceeds the capacity limit for this server.

 

 

When trying to update phpbb on my Uniserver install I get that above error.

 

Can anybody help with this error?

 

Sorry I have not been around for a while my personal life has not allowed me the time to be here.

 

I am using version 7.1.11-Orion please dont beat me up too bad for this I will be happy to upgrade to the latest version I wanted to get this phpbb upgrade taken care of first.

 

Thanks in advance for the help.

 

 

While I am waiting for a reply I will download and install the latest version.



#2 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 22 January 2014 - 06:05 AM

In Apache configuration file  httpd.conf increase Apache limits for limit request line and limit request field size.

Note: Defaults
LimitRequestLine 8190
LimitRequestFieldSize 8190

All the best
Ric



#3 rustyp

rustyp

    Member

  • Member
  • PipPip
  • 73 posts
  • Main OS: Windows Vista

Posted 22 January 2014 - 09:06 AM

In Apache configuration file  httpd.conf increase Apache limits for limit request line and limit request field size.

Note: Defaults
LimitRequestLine 8190
LimitRequestFieldSize 8190

All the best
Ric

Hi thanks for the reply,

I search for the file httpd.conf opened it then searched for LimitRequestLine and LimitRequestFieldSize neither one of them are in the httpd.conf file am I looking in the right place?

 

Thanks



#4 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 22 January 2014 - 12:37 PM

Not a problem add above two lines to the end of httpd.conf and increase default values.

 

 

All the best

Ric



#5 rustyp

rustyp

    Member

  • Member
  • PipPip
  • 73 posts
  • Main OS: Windows Vista

Posted 22 January 2014 - 01:44 PM

Ok I added the two lines at the very bottom of the httpd.conf file, then saved the file then restarted Apache and it still gives me the same error.

 

LimitRequestLine 5000
LimitRequestFieldSize 5000

 

Am I doing something wrong or havent raised the number high enough?

 

Thanks again.



#6 rustyp

rustyp

    Member

  • Member
  • PipPip
  • 73 posts
  • Main OS: Windows Vista

Posted 24 January 2014 - 11:32 AM

Ok I have increase the settings all the way up to 30000 and am still getting the same error.

Changed the settings saved the file then restarted the Apache service.

 

LimitRequestLine 30000
LimitRequestFieldSize 30000

 

Request-URI Too Large

The requested URL's length exceeds the capacity limit for this server.

 

Suggestions?

 

Thanks again.



#7 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 24 January 2014 - 01:30 PM

Generally default settings (8190 ) for Apache should not be changed. You have increasing these values to 30000 which has not resolved the issue. I conclude you are trying to send an excessive amount of data using the GET method try using the POST method instead remember to delete the two lines you added.

 

Although I am not familiar with phpbb it suggests this is the issue. It may be the result of incorrect settings in phpbb or a macro or script you have added to this application.

 

If no one on this forum can help try asking the same question on the phpbb forum.

 

All the best

Ric



#8 rustyp

rustyp

    Member

  • Member
  • PipPip
  • 73 posts
  • Main OS: Windows Vista

Posted 27 January 2014 - 09:31 AM

Yes I suspect phpbb has a problem with their software I have tried the same thing on hostgator and its not working their either getting different errors, its actually two different problems on hostgator.

 

Sadly the problems and errors will go unreported because of the micky mouse way phpbb administers their message board they chase away more users than they get to help them, I am done with trying to post on the phpbb message board over the years I have created 11 accounts, 11 different emails, each time I come across a new problem then return my account does not work says my password is bad cant get a new password its a real cycle of stupid more than once I have given a moderator all my emails and user names ask them to delete them all they dont, most the admin at that site is ego and emotional driven I am done with them if these current problems cant be resolved I will dump phpbb and go with something else even if its a lesser product at least I dont have to deal with the morons that run the program.

 

Sorry for the phpbb rant.

 

Thanks so much for all your help you have a great setup I have been in love with since the first time I installed.

 

I installed your latest build and must say I like the user interface and admin panel of Uniform Server 7.1.11-Orion much better.

 

 

Thanks again.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users