Jump to content


Photo

How do you change the UNIserver port?

uniserver port change

  • Please log in to reply
8 replies to this topic

#1 Dragosvr92

Dragosvr92

    Newbie

  • Member
  • Pip
  • 6 posts
  • Gender:Male
  • Main OS: Windows 7

Posted 23 August 2015 - 03:55 AM

Hello,

 

I havent been using UNIserver in a while, and meanwhile, ive got a router and updated to Windows 10 64bit.

 

When i try to run UniController (v1.2.0.11), i am told port 80 is in use by another program, and i am instructed to change the uni server port.

But it provides no instructions as to how i would be able to do that. Kept Googling but theres nothing straight forward.

 

I got across this page, and scanned for port 80 and it returned this:

>netstat -ano | find "LISTENING" | find ":80"
  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       4
  TCP    [::]:80                [::]:0                 LISTENING       4

Not sure what thats saying, i guess port 80 is in use by the router, or an w10 service.

 

Either way, i would like to change the uniserver port to something else and get it working again.

Thank you :)

 

Btw, after i posted this message, i got;
 

An error occured with the SQL server:

mySQL query error: SELECT cs_value, cs_updated FROM ibf_cache_store WHERE cs_key='mail_processing'

This is not a problem with the IPS Community Suite but rather with your SQL server. Please contact your host and copy the message shown above.

 

But it seemed to get posted.



#2 Dragosvr92

Dragosvr92

    Newbie

  • Member
  • Pip
  • 6 posts
  • Gender:Male
  • Main OS: Windows 7

Posted 24 August 2015 - 12:54 AM

Any help please?



#3 gratzo

gratzo

    Junior Member

  • Member
  • Pip
  • 32 posts

Posted 24 August 2015 - 12:27 PM

I just got the server to run on my Windows 10, 64 bit system, and it took a little bit of fooling around.  When I clicked on the UniController, it gave the errors that port 80 was already in use.  Every time you start your machine, Windows 10 will likely start IIS, which I believe opens port 80, so, you either have to turn off IIS, or change the port in Uniform Server.  (but of course, if you can't get to the controller to change the port, you're stuck).

 

 IIS, the World Wide Web Publishing Service is more than likely the culprit.

 

Here's what I did - 

 

- go to: Control Panel > Administrative Tools > Services > scroll to the bottom and right click on World Wide Web Publishing Service > select Properties

- click Stop

- in Startup type: select Manual

- click Apply and then OK

- make sure that the UniController is also not running (if it is, you can stop it in this same window).

- click on the UniController again (right click, open as Administrator), and it should open the controller correctly this time

- change the port to anything but 80 and you should be OK.

 

Let me know if this works.

(you may want to change your profile to Windows 10, as W7 has different menu's/etc)



#4 Dragosvr92

Dragosvr92

    Newbie

  • Member
  • Pip
  • 6 posts
  • Gender:Male
  • Main OS: Windows 7

Posted 25 August 2015 - 04:02 AM

After i finally manage to find Control Panel > Administrative Tools > Services >

I couldnt find World Wide Web Publishing Service in there. But, a day after i posted this, i reinstalled W10 and kept the files and had it dump all programs and settings.

 

I thought doing that may have fixed it, and it appears it did. I think the devs should add an option where to change the ports if you are unable to clear port 80 to run the aplication.

 

Btw, do you by any chanche know how i could set uniserver to remember my mysql pass? Each time i start the service, it asks to retype the password.



#5 Lyle

Lyle

    Support Team Member

  • Support Team
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:Calgary, AB Canada
  • Interests:GeneratePress
    Elementor
    WP Show Posts
    WordPress
  • Main OS: Windows 8

Posted 31 August 2015 - 11:15 PM

1. If it's a default Win 10 Home / Pro version, WWW Publishing will be in the Services list, near the bottom ... see screenshot :)

 

2. The devs do have the option built in to change the ports :) From the UniController (Note - Apache must be stopped to make the change): Apache > Change Apache Ports > Change Apache Port > enter port number > click OK :)

 

3. See my last reply in this thread:  http://forum.uniform...wtopic=3087&hl=

 

 

 

MT66db7.png


GeneratePress / Elementor / WP Show Posts / Do It Yourself WordPress - Sniffle Valve

 

You want a WordPress website and you want it now - GOOD CHEAP FAST WEBSITES

 

Don't take life too seriously ... nobody has ever gotten out of it alive  :)

 

 


#6 MarkHoward

MarkHoward

    Newbie

  • Member
  • Pip
  • 6 posts
  • Main OS: Other

Posted 18 November 2015 - 08:42 PM

The Console will not start because Port 80 is being used by some other service.

You should change the default port for Apache.

You can't get access to Change Apache Ports until the Console is running.

 

The Console will not start because Port 80 is being used by some other service.

You should change the default port for Apache.

You can't get access to Change Apache Ports until the Console is running.

 

Any help?

 



#7 cxdani

cxdani

    Newbie

  • Member
  • Pip
  • 1 posts
  • Main OS: Windows 8

Posted 05 January 2016 - 06:51 PM

You can manually change the ports in UniServerZ\home\us_config\us_user.ini 

 

Eg:

 

[USER]
;
;-- Apache
;
AP_PORT=8080
AP_SSL_PORT=9443


#8 fr3d3r1ck

fr3d3r1ck

    Newbie

  • Member
  • Pip
  • 9 posts
  • Gender:Male
  • Location:127.0.0.1
  • Interests:< / >
  • Main OS: Other

Posted 05 January 2016 - 09:19 PM

@cxdani: yes, it's probably the most easy solution to do this. ;)


Unless someone like you cares a whole awful lot, nothing is going to get better. It's not. – Dr. Seuss


#9 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 08 January 2016 - 02:41 PM

The Console will not start because Port 80 is being used by some other service.
You should change the default port for Apache.
You can't get access to Change Apache Ports until the Console is running.

 

This is a bug. The controller should remain open allowing the ports to be changed.
Corrected in version 12.0.1-ZeroXII  and new controller ZeroXII_controller_2_1_0.exe

To update an existing server:
Copy ZeroXII_controller_2_1_0.exe to a temporary folder.
Double click on the above file to extract its content.
Copy the extracted file UniController.exe to your existing server.
Delete the temporary folder its no longer required.

All the best
Ric






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users