Jump to content


Photo

Can't run CGI scripts with nix shabang


  • Please log in to reply
3 replies to this topic

#1 flamey

flamey

    Newbie

  • Member
  • Pip
  • 1 posts
  • Main OS: Windows Vista

Posted 19 January 2010 - 08:49 AM

I downloaded version 5.5-Nano last night, but my Perl CGI scripts with nix shebang line do not work. Only after I change that line to my current ActiveState Perl install #!C:\Perl\.... it starts working.

I see there are some examples on Wiki pages with #!/usr/bin/perl , what am I doing wrong?

#2 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 19 January 2010 - 04:51 PM

You are doing nothing wrong, as you have observed shebangs are and need to be different. ;)

This page is worth a read:

http://wiki.uniforms.../5.0-Nano:_Perl

All the best
Ric :)

#3 elliot100

elliot100

    Newbie

  • Member
  • Pip
  • 3 posts
  • Main OS: Windows Vista

Posted 15 June 2010 - 03:08 PM

Isn't this behaviour a change from version 4 to 5 though? If so, shouldn't the Wiki page mention that?

#4 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 15 June 2010 - 05:08 PM

Documentation is reasonable! Probably will never catch up. That said the Wiki is open you can edit pages accordingly.

If you are still using 4 series for production, consider upgrading to 5.6.6 there have been a number of security updates.

All the best
Ric :angry:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users