Jump to content


JaggedJax

Member Since 07 Aug 2015
Offline Last Active Nov 16 2016 09:06 PM
-----

Topics I've Started

Enable SSL for MySQL

04 October 2016 - 07:39 PM

I'm trying to enable SSL in MySQL, but having trouble with UniServer. Following the directions I find online and SSL is always still disabled.

 

Is there a trick to it with Uniserver? I used the Generate_server_cert_and_key batch file for apache, and tried re-using those keys. I also tried creating new keys from scratch, but the openssl this comes with throws an error saying "unknown option -CAKey" which apparently is not an issue anyone on the internet has ever had :-/

 

Here are the lines I added the mysqld section of my.ini. I can tell the keys paths are loaded in MySQL, but it still says have_openssl and have_ssl are disabled.

ssl
ssl-ca     = "C:/UniServerZ/core/apache2/server_certs/ca.pem"
ssl-cert   = "C:/UniServerZ/core/apache2/server_certs/sub.class1.server.ca.pem"
ssl-key    = "C:/UniServerZ/core/apache2/server_certs/server.key"

Apache Access and Password missing IPv6 entry for Intranet Access

17 February 2016 - 08:22 PM

When going to the Access and Passwords screen and setting the Server Access to "Local and Intranet Access" it creates a .htaccess file that is correct for ipv4, but only allows localhost for ipv6.

 

The fix for this seems to be adding the following entry to the ipv6 Allow rule if the user wants to allow Intranet Access: FE80::/64

 

Eg: Allow from ::1 FE80::/64

 

I'm not sure if there are multiple localhost ranges for ipv6, but that is the main one.

 

This is needed in scenarios where you want to access the web server using the server name and the os or dns entry defaults to ipv6.


UniServer Zero XII Missing FTP Support?

17 February 2016 - 02:15 PM

It seems like UniServer Zero XII with PHP 7 may be missing ftp support. I get the Undefined function error when trying to call ftp_connect, and the phpinfo() result is missing the FTP section that says "ftp support enabled". That section is there if I install the php 5.6 module.