Jump to content


Photo

US running on a thin client - this is great! - Thanks!


  • Please log in to reply
6 replies to this topic

#1 vtitguy

vtitguy

    Newbie

  • Member
  • Pip
  • 2 posts

Posted 19 July 2007 - 10:20 AM

Thanks for a great setup. I've been wanting to setup a small XAMP server at home but didn't really want a PC running all the time. I've now got US running on a Wyse Winterm XP embedded thin client. Low power, no fan noise and it fits on a bookshelf. What more could you want? :D

For anyone interested, the only probem I came across was the absence of a NULL device for Apache. US would crash on startup. The Apache error log showed "Unable to connect child stdout to NUL." After some searching I found an easy way to install. Here are the instructions for anyone interested.

Need to have administrative permissions on system!

1. Copy null.sys from a Windows XP PC (c:\windows\system32\drivers\null.sys) to the same location on the thin client.

2. Open regedit to: HKLM-System-CurrentControlSet-Enum
Change permissions on Root to Administrator - Full control

3. Create key HKLM-System-CurrentControlSet-Enum-Root-LEGACY_NULL

4. Save registry info below as NullDriverRegistry.reg (copy everything between the asterisk lines and paste into notepad) and add to registry

5. Should merge successfully. Reboot.

6. To confirm it worked, go to Device Manager, select Show hidden devices from the View menu. Open Non-Plug and Play drivers and find Null. Double-click and make sure the status say "This device is working properly."

*************NullDriver.reg*******************

Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{8ECC055D-047F-11D1-A537-0000F8753ED1}]
"Class"="LegacyDriver"
@="Non-Plug and Play Drivers"
"NoDisplayClass"="1"
"SilentInstall"="1"
"NoInstallClass"="1"
"EnumPropPages32"="SysSetup.Dll,LegacyDriverPropPageProvider"
"Icon"="-19"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_NULL]
"NextInstance"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_NULL\0000]
"Service"="Null"
"Legacy"=dword:00000001
"ConfigFlags"=dword:00000020
"Class"="LegacyDriver"
"ClassGUID"="{8ECC055D-047F-11D1-A537-0000F8753ED1}"
"DeviceDesc"="Null"
"Capabilities"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_NULL\0000\LogConf]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_NULL\0000\Control]
"ActiveService"="Null"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Null]
"ErrorControl"=dword:00000001
"Group"="Base"
"Start"=dword:00000001
"Tag"=dword:00000001
"Type"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Null\Enum]
"0"="Root\\LEGACY_NULL\\0000"
"Count"=dword:00000001
"NextInstance"=dword:00000001


***************************************************

#2 megan

megan

    Support Team Member

  • Support Team
  • PipPip
  • 92 posts

Posted 19 July 2007 - 10:32 AM

Thanks for a great setup. I've been wanting to setup a small XAMP server at home but didn't really want a PC running all the time. I've now got US running on a Wyse Winterm XP embedded thin client.


So I have to ask - how much does a device like this cost ??? thanks, Megan

#3 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 19 July 2007 - 01:59 PM

Cool :D

#4 vtitguy

vtitguy

    Newbie

  • Member
  • Pip
  • 2 posts

Posted 25 July 2007 - 12:47 PM

[quote name='vtitguy' date='Jul 19 2007, 11:20 AM' post='5407']

I think this one cost about $400. They are short on disk space (they use flash memory) but you can run US on a connected USB drive instead of using the built in flash. So far it's been working great. I have two sites running.

#5 idi_mac

idi_mac

    Newbie

  • Member
  • Pip
  • 1 posts
  • Main OS: Windows XP

Posted 11 October 2007 - 08:24 PM

This post was a great help!
I am running Apache on XPE and was going crazy with this NULL.SYS issue.

I wanted to add that on one of my machines, I need to double click NULL under Device Manager and change the startup type to Automatic.
This only happened on one machine, but it took a few hours to find it.

#6 Vampier

Vampier

    Newbie

  • Member
  • Pip
  • 4 posts
  • SourceForge IDVampier
  • IRC Nickname: Vampier
  • Main OS: Windows Vista

Posted 11 September 2009 - 05:15 AM

FYI: This also works on Windows For Legacy PCs
openMSX the best MSX emulator out there

#7 ctopher

ctopher

    Newbie

  • Member
  • Pip
  • 5 posts
  • Main OS: Windows 2000

Posted 01 June 2010 - 02:12 PM

Does your Wyse Winterm use a VIA processor?

I see that they have many flavors with different processor speeds and memory sizes. Do you know the specs of your box? or the model number and we can look it up?

Thanks for the info about dev/null! 7 registry entries to support a NUL device. Don't you just love windows? (Yes, Win2K is my main OS!)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users