Jump to content


Photo

PhpMyAdmin error win down grading php 5 to php 4


  • Please log in to reply
15 replies to this topic

#1 aaea73

aaea73

    Newbie

  • Member
  • Pip
  • 6 posts
  • Main OS: Windows Vista

Posted 26 August 2007 - 08:04 PM

I've downloaded the uniform server version 3.5. It works great on my xp home edition OS. Now I wanted to use the php 4 plugin. Since it is my understanding that I can't have 2 versions of php running on the same machine, I've downloaded the php4 plugin, deleted all the files and folders under my already installed C:\Uniform Server\udrive\usr\local\php folder, copied the exracted files and folders from the downloaded plugin into that same folder (i.e, C:\Uniform Server\udrive\usr\local\php). I've also changed the LoadModule php5_module "/usr/local/php/php5apache2.dll" line in the httpd.conf file located in C:\Uniform Server\udrive\usr\local\apache2\conf into LoadModule php4_module "/usr/local/php/php4apache2.dll". Now, when I access the phpinfo() from the admin panel I get the information about php4 installed. The problem is phpMyAdmin gives me the following error"Couldn't load the iconv or recode extension needed for charset conversion. Either configure PHP to enable these extensions or disable charset conversion in phpMyAdmin."

I don't have any installed php on my machine before. just the Uniform server and the downloaded extracted files of Apollo 3.5 and php4.x.x, any suggestions?

#2 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 26 August 2007 - 08:35 PM

Go to php.net and download that version of the 4.x plugin. Look for the php_iconv.dll extension and then edit the php.ini to enable it... or just goto the config.inc.php in the /home/admin/www/phpMyAdmin folder... edit it, and look for where it mentions charset conversion.

#3 aaea73

aaea73

    Newbie

  • Member
  • Pip
  • 6 posts
  • Main OS: Windows Vista

Posted 27 August 2007 - 12:48 AM

Go to php.net and download that version of the 4.x plugin. Look for the php_iconv.dll extension and then edit the php.ini to enable it... or just goto the config.inc.php in the /home/admin/www/phpMyAdmin folder... edit it, and look for where it mentions charset conversion.


Would you elaborate more on the edits I need to apply to the config.inc.php in the /home/admin/www/phpMyAdmin folder?

Thanks

#4 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 27 August 2007 - 01:13 AM

I really cant right now cause i dont have a copy with me and cant one at the moment, so i dont know what setting it would be but can you copy and paste the whole thing to the Pastebin: http://www.uniformserver.com/pastebin

#5 aaea73

aaea73

    Newbie

  • Member
  • Pip
  • 6 posts
  • Main OS: Windows Vista

Posted 27 August 2007 - 04:39 PM

I have posted the config.inc.php to the http://www.uniformserver.com/pastebin. It would be graet if you can show what edits need to be made.

Thanks

#6 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 27 August 2007 - 09:05 PM

When y make a post to the pastebin.. you give us the entire link.. not the link to the main pastebin.... or we wont know where it is as it gets spammed... you have to give us the link to your post???

#7 aaea73

aaea73

    Newbie

  • Member
  • Pip
  • 6 posts
  • Main OS: Windows Vista

Posted 28 August 2007 - 04:54 PM

The link is http://www.uniformse.../pastebin/43139

Thanks

#8 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 28 August 2007 - 06:54 PM

Sorry.... i did not see it but i think thats due to the spamming :lol: I have moved the whole pastebin to a new directory, http://www.uniformserver.com/bin/ Post it there and let me know.

Thanks.

#9 aaea73

aaea73

    Newbie

  • Member
  • Pip
  • 6 posts
  • Main OS: Windows Vista

Posted 30 August 2007 - 11:28 AM

I posted it again on http://www.uniformserver.com/bin/43206

Thanks

#10 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 30 August 2007 - 06:46 PM

Here you go: http://www.uniformserver.com/bin/43207

Copy it to the file, and it should work.

#11 aaea73

aaea73

    Newbie

  • Member
  • Pip
  • 6 posts
  • Main OS: Windows Vista

Posted 30 August 2007 - 11:29 PM

I used your code to replace the code in the Config.inc.php that exists under C:\Uniform Server\udrive\home\admin\www\phpMyAdmin. I still got the same "Couldn't load the iconv or recode extension needed for charset conversion. Either configure PHP to enable these extensions or disable charset conversion in phpMyAdmin." error. Help!

#12 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 02 September 2007 - 02:07 PM

Iconv is not supported in PHP 4, its a PHP 5 extension thats being used by new versions of PHPMyAdmin. It seems this version has a bug or something if we cant get it to turn that model off and not to allow it to use it....

Did you turn the server off before trying this step?

#13 rado

rado

    Newbie

  • Member
  • Pip
  • 2 posts
  • Main OS: Windows XP

Posted 26 February 2008 - 05:42 AM

I've downloaded the uniform server version 3.5. It works great on my xp home edition OS. Now I wanted to use the php 4 plugin. Since it is my understanding that I can't have 2 versions of php running on the same machine, I've downloaded the php4 plugin, deleted all the files and folders under my already installed C:\Uniform Server\udrive\usr\local\php folder, copied the exracted files and folders from the downloaded plugin into that same folder (i.e, C:\Uniform Server\udrive\usr\local\php). I've also changed the LoadModule php5_module "/usr/local/php/php5apache2.dll" line in the httpd.conf file located in C:\Uniform Server\udrive\usr\local\apache2\conf into LoadModule php4_module "/usr/local/php/php4apache2.dll". Now, when I access the phpinfo() from the admin panel I get the information about php4 installed. The problem is phpMyAdmin gives me the following error"Couldn't load the iconv or recode extension needed for charset conversion. Either configure PHP to enable these extensions or disable charset conversion in phpMyAdmin."

I don't have any installed php on my machine before. just the Uniform server and the downloaded extracted files of Apollo 3.5 and php4.x.x, any suggestions?


Hello,

I am stuck in the same situation.
I tried enabling the iconv extension (php.ini; dlls in place with paths etc.), but the message was the same again.
I tried to disable the charset conversion in phpMyAdmin configuration, but it didn't work as well.
Actually I tried everything I found on this forum, but it doesn't get any better.
And... yes - I do turn off and on the server on every try. :)

Please, let me know if there is a working way to get rid of this error.

Rado

#14 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 27 February 2008 - 10:07 AM

How to downgrade PHP 5 to PHP 4.4.8 for 3.5-Apollo

A) Download full version of PHP 4.4.8
1) Create a new folder named c:\php448
2) Download and save the following file into the above folder:
a) Goto: http://www.php.net/downloads.php
b ) Scroll down the page to: Windows Binaries
c) Download this file: PHP 4.4.8 zip package [8,434Kb] - 12 Feb 2008
md5: 09ffff4b1a54bbadb8fee6acd85a2c1f
3) Right click on file and select Extract All, click NEXT(no need to change path), click NEXT again.

B ) Install a clean version of Uniform Server 3.5-Apollo on C drive
1) Start and stop the servers. Make sure they work and train any security software.
2) Backup php.ini - Install PHP
a) Copy php.ini from C:\Uniform Server\udrive\usr\local\php to C:\Uniform Server
b ) Delete the contents of folder C:\Uniform Server\udrive\usr\local\php
c) Copy the contents of folder C:\php448\php-4.4.8-Win32\php-4.4.8-Win32
To folder: C:\Uniform Server\udrive\usr\local\php
d) Copy php4apache2.dll from: C:\Uniform Server\udrive\usr\local\php\sapi
To folder: C:\Uniform Server\udrive\usr\local\php
e) Copy iconv.dll from: C:\Uniform Server\udrive\usr\local\php\dlls
To folder: C:\Uniform Server\udrive\usr\local\php
f) Copy libmysql.dll from: C:\Uniform Server\udrive\usr\local\php\dlls
To folder: C:\Uniform Server\udrive\usr\local\php
g) Restore php.ini: Copy php.ini from C:\Uniform Server to C:\Uniform Server\udrive\usr\local\php

C) Edit php.ini
1) Locate the line: ;extension=php_iconv.dll and change to extension=php_iconv.dll
2) Locate the line: extension=php_mysql.dll and change to ;extension=php_mysql.dll
3) Locate the line: extension=php_mysqli.dll and change to ;extension=php_mysqli.dll
4) Locate the line: extension=php_pdo.dll and change to ;extension=php_pdo.dll
5) Locate the line: extension=php_sqlite.dll and change to ;extension=php_sqlite.dll

D) Edit Apache httpd.conf located in folder:
C:\Uniform Server\udrive\usr\local\apache2\conf
1) Locate the line: LoadModule php5_module "/usr/local/php/php5apache2.dll"
Change to: LoadModule php4_module "/usr/local/php/php4apache2.dll"

E) Edit the phpMyAdmin file: config.inc.php located in folder:
C:\Uniform Server\udrive\home\admin\www\phpMyAdmin
1) Locate the line : $cfg['Servers'][$i]['extension'] = 'mysqli';
Change to : $cfg['Servers'][$i]['extension'] = 'mysql';

F) Edit my-small Located in folder:
C:\Uniform Server\udrive\usr\local\mysql\bin
1) Under this line port=3306 add the following two new lines:

#Use old password encryption method (needed for 4.0 and older clients).
old_passwords

Restart the servers; from apanel check that PHP 4.4.8 info is displayed.
Click on phpMyAdmin expected error displayed is:

#1251 - mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client”

PHP4 uses short password hashes as opposed to PHP5’s long one’s. Anyway it shows PHP4 is working and phpMyAdmin. To correct the above do not turn the servers off and follow these instructions:

G) Open a command prompt (start > run > type cmd and press OK)
H) Type the following and press return at the end of every line:

W:
Cd usr\local\mysql\bin
mysql -u root –p


I) When requested enter the password root
J) You are now at the MySQL command prompt. Type the following and press return:

SET PASSWORD FOR 'root'@'localhost' =OLD_PASSWORD('root');

Query OK indicates you have created a short password hash. Close the command prompt window (top right cross).
Restart the servers; check you can access MySQL using phpMyAdmin.

K) From apanel run phpMyBackupPro,
a) Login as root root,
b ) Select the configuration tab,
c) Change the MySQL password to root
d) Finally click Save Data

Phew! That’s it

All the best
Ric :)

#15 rado

rado

    Newbie

  • Member
  • Pip
  • 2 posts
  • Main OS: Windows XP

Posted 28 February 2008 - 07:24 AM

Thank you very much, Ric. That was a really good and helpful one. It actually worked. :)

I'm not sure if I had to, but I made some more changes, as I had the same errors whatever I tried to do:

1. I inserted "old_passwords=1" in the "my-small" instead of "old_passwords" alone. (don't know why)

2. And the other in the "config.inc.php":
$cfg['AllowAnywhereRecoding'] = FALSE;
//$cfg['RecodingEngine'] = 'auto';
//$cfg['IconvExtraParams'] = '';

3. I cleared the temp files of the IE... Maybe this was the problem and my added changes were not needed. :)

Thanks again,
Rado

#16 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 28 February 2008 - 10:36 AM

Excellent glad its working and thanks for the feedback:

1) My fault it should have been "old_passwords=1"

2) Not sure about this one, the manual states:

$cfg['AllowAnywhereRecoding'] boolean
Allow character set recoding of MySQL queries. You need recode or iconv support (compiled in or module) in PHP to allow MySQL queries recoding and used language file must have it enabled (by default only these which are in Unicode, just to avoid losing some characters).

Setting this to TRUE also activates a pull-down menu in the Export page, to choose the character set when exporting a file.


It looks as if setting it to “False” should not be an issue however bear it in mind if you do have problems.

All the best
Ric :)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users