Jump to content


Photo

Enabling extensions crashes Apache


  • Please log in to reply
1 reply to this topic

#1 jdk

jdk

    Junior Member

  • Member
  • Pip
  • 19 posts
  • Main OS: Windows XP

Posted 07 March 2011 - 10:15 AM

Hello,
I am using version 5.7.4 to test Moodle 2.0. The pre-installation check tells me that I need to enable the soap and intl extensions. In addition, I need to enable ldap. When I enable them, Apache service fails to start. Only when I comment out the appropriate lines in php.ini, does Apache start properly.

Has anyone advice as to how to solve this problem?
Many thanks,
Jeff

Edit: I've partially solved this. I also needed to enable soap. I've done this, removed the ldap and intl dll files that I added, and commented the php_ldap and php_intl lines in php.ini.

After restarting services, Apache starts properly, but I need to enable the intl and ldap extensions. I downloaded the windows binaries from php.net for version 5.3.5. This is the version shown in phpinfo() I extracted the downloaded file and copied the 2 .dll files from the \ext directory.

However, when I uncomment php_ldap and php_intl in phph.ini, apache fails to start. Have I done something incorrectly?

Thanks,

Jeff

#2 jdk

jdk

    Junior Member

  • Member
  • Pip
  • 19 posts
  • Main OS: Windows XP

Posted 07 March 2011 - 02:51 PM

Edit: I've partially solved this. I also needed to enable soap. I've done this, removed the ldap and intl dll files that I added, and commented the php_ldap and php_intl lines in php.ini.

After restarting services, Apache starts properly, but I need to enable the intl and ldap extensions. I downloaded the windows binaries from php.net for version 5.3.5. This is the version shown in phpinfo() I extracted the downloaded file and copied the 2 .dll files from the \ext directory.

However, when I uncomment php_ldap and php_intl in phph.ini, apache fails to start. Have I done something incorrectly?

Thanks,

Jeff

I have worked out the ldap issue - it was caused by downloading and copying the wrong binaries. I am now using VC6 Thread safe binaries. LDAp loads properly now, but the intl extension continues to crash Apache. The error log simply says ":/Content/TestServers/UniServer5_7_4/UniServer/usr/local/apache2/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run".




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users