Jump to content


Alfred

Member Since 21 Aug 2019
Offline Last Active Oct 13 2019 05:09 AM
-----

Posts I've Made

In Topic: US 13.4.0 PHP 7.3 cURL

01 September 2019 - 02:34 PM

Just installed the new version, works great!

Only one small detail: when I click "About" it still shows it's version 13.4.0.

Thanks for the quick and good follow up brainstorm!

In Topic: US 13.4.0 PHP 7.3 cURL

26 August 2019 - 08:08 AM

How do you check the curl extension is "really" working ? (i guess the GLPI installation just check it is "available")


I used a small PHP file, or just check phpinfo. In my previous case, cURL was "on" in the config files, Apache started without errors, but cURL didn't show up.
<?php
if  (in_array('curl', get_loaded_extensions())) {
    echo "CURL is available on your web server";
} else {
    echo "CURL is not available on your web server";
}
?>
I re-tried copying the given DLL files to the Apache/bin folder and restarted my computer. Looks OK for now, which is strange as I already did this the last time (without restarting though). I'm not sure wat the cause of this issue was, but it is solved for now. Thanks!

In Topic: US 13.4.0 PHP 7.3 cURL

23 August 2019 - 01:56 AM

Yes, but that is OK I think. Path etc were already correct, no files copied to system32.

 

I've located on how to trigger the issue:

- Installing the new US in folder "uniserver"

- Older version in folder "server"

 

Running the new version, start without errors, but no curl. cURL is enabled, but not working, but also not showing errors. When i shutdown the new version, start the old version, stop and shutdown the old version, restart the new one, it throws the above DLL errors.

 

So basicly I can run a fresh installation of US with cURL enabled, without errors, but cURL not working (weird?). After working in the old version, the new one gets corrupted and throws errors.