Jump to content


Photo

DBI module


  • Please log in to reply
6 replies to this topic

#1 MartinTygsen

MartinTygsen

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 15 August 2005 - 11:20 AM

Hello,

Thanks for a exelent package with perl apache mysql etc.

I am used to the PPM from activestate because i run Windows XP

But my problem is that I cant use PPM in the uniform server, so I really dont know how to install the DBI module.

I tried installing it with
perl makefile.pl
and then

dmake ( alså tried nmake and just make)
but none of them worked, I never tried installing a module that way, and I'm kinda new at perl.

So I hope some one would help me install DBI module on my Windows XP.

(Why not include the DBI module in the next release, its a comon and well used module.)

Many thanks

Best Regards
Martin Tygsen

#2 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 15 August 2005 - 01:04 PM

Hmmm... i really don't use Perl much but will this topic help: http://forum.uniform...p?showtopic=141

Or you can check the other topic in here: http://forum.uniform...p?showtopic=149

Trying to be a little lazy today... :P

About the module i will see what i can do... maybe in 3.3

Thanks ;)

#3 MartinTygsen

MartinTygsen

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 16 August 2005 - 10:15 AM

Hmmm... i really don't use Perl much but will this topic help: http://forum.uniform...p?showtopic=141

Or you can check the other topic in here: http://forum.uniform...p?showtopic=149

Trying to be a little lazy today... ;)

About the module i will see what i can do... maybe in 3.3

Thanks :D

View Post


No I tried it allready but no :P

It would be great if you could take det dbi module in 3.3, I understand if you dont have the time to help me, so I will try in another forum or install apahce mysql perl my self on the hard way :D

Thanks alot for a great product, and I will check in regular to se if there is any changes in the version number.

If its possibly to make det PPM a plugin to the UniServ it would be more than GREAT

#4 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 16 August 2005 - 10:21 AM

i will see what i can do... I will try and add the DBI Module into 3.3

#5 MartinTygsen

MartinTygsen

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 16 August 2005 - 11:46 AM

i will see what i can do... I will try and add the DBI Module into 3.3

View Post


Okay thanks, I am sure many people will be happy about it.

#6 helsby

helsby

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 31 August 2005 - 07:26 PM

I'd like that too as I've just tried to install MT onto the server and it fails as it needs DBD:Mysql and the mt instructions say "
If you need to install DBD::mysql, DBD::Pg, or DBD::SQLite

If your server does not have the required DBD module, you should first consider using Movable Type's Berkeley DB support (the default).

Otherwise, you will need to contact your hosting provider and ask them to install the DBI module and whichever of the above modules is necessary to connect to your database. Note that your account will need access to a SQL database, apart from the existence of these modules, in order for you to use Movable Type's SQL database support.



#7 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 01 September 2005 - 09:34 AM

k, i will work on that :(




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users