Jump to content


Photo

localhost


  • Please log in to reply
8 replies to this topic

#1 JohnHolland

JohnHolland

    Newbie

  • Member
  • Pip
  • 9 posts
  • Location:Amersfoort, Netherlands

Posted 21 July 2005 - 11:29 AM

Hi,
i am getting the error message "connection refused while atttempting to contact to local host". Is this a firewall problem or antivirus-software problem? I am using Windows2000 with the Norton Symantic Client Firewall and Norton anti-virus software on a laptop,
cheers,
JH

#2 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 21 July 2005 - 11:52 AM

You are suppose to connect to http://localhost, no spaces..... :P

#3 JohnHolland

JohnHolland

    Newbie

  • Member
  • Pip
  • 9 posts
  • Location:Amersfoort, Netherlands

Posted 21 July 2005 - 01:32 PM

You are suppose to connect to http://localhost, no spaces..... :P

View Post



I get this error when i run the start.bat file. The W-drive is created, but then i get the error message. So where am i supposed to make that connection ?

#4 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 21 July 2005 - 05:24 PM

Try refreshing it.. it may take a while for the server to load....

Or try going to http://localhost 35 seconds later...

#5 vproman

vproman

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 30 July 2005 - 08:51 PM

I am having similar problem.

I can access my website by going to http://localhost just fine. When I try to access the website externally though, I get connection refused.

At first I was getting a 404 message, but this was from IIS and so I uninstalled it. Now I simply get "connection refused."

I do not have a .htaccess or .htpasswd file in my main www directory at all, or any of the sub directories for that matter.

edit: I am using Windows 2000 Server. Is it possible that the .htaccess file is hidden? I set Folder Options to "show hidden files and folders" and even disabled "hide protected os files" and still don't see any. Are there some access settings in the security tab of the folders that I have to change?

edit: from a somewhat similar post...

A. Do you have Skype installed?
nope, this prob isn't related.

B. Do you have an Anti-Virus Software Installed?
AVG 6.0 but I used to use IIS on 80 and it worked fine (IIS is not completely uninstalled).

C. Is your Anti-Virus Software blocking port 80?
Prob not, see above.

D. Do you have a drive on your PC already named W:/?
Nope, just my main HD.

E. Do you have any other programs that might be using or blocking port 80?
DynDNS updater and NO-IP DUC but I believe these use alt ports and not port 80.

F. Do you have a drive named W:/?
I have a drive named W but only after I use start.bat so it is the Uniserver drive.

G. What OS is your computer running?
Windows 2000 Server

H. What error does it bring up?
Worked fine when I access it from within my computer i.e. http://localhost but when trying to access from outside network

#6 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 30 July 2005 - 09:03 PM

Are u using a router? and where are u access the server from? Another PC on the network or where?

If you are using a router, u will need to open and forward the port to that PC the server is on.

#7 vproman

vproman

    Newbie

  • Member
  • Pip
  • 3 posts

Posted 30 July 2005 - 09:22 PM

Are u using a router? and where are u access the server from? Another PC on the network or where?

If you are using a router, u will need to open and forward the port to that PC the server is on.

View Post


I am using a router and you were right, I did have to mess around with the port forwarding a bit to get it to work properly. This was also a huge help, thank you to the person who wrote it!

I am accessing it on another computer behind the network, but via a dyndns redirector, plus canyouseeme.org is finally saying it can see my service.

#8 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 30 July 2005 - 09:47 PM

lol.. Bincho wrote it, O.K. :P ;)

#9 JohnHolland

JohnHolland

    Newbie

  • Member
  • Pip
  • 9 posts
  • Location:Amersfoort, Netherlands

Posted 31 July 2005 - 01:12 AM

I am having similar problem.

I can access my website by going to http://localhost just fine.  When I try to access the website externally though, I get connection refused.

At first I was getting a 404 message, but this was from IIS and so I uninstalled it.  Now I simply get "connection refused."

I do not have a .htaccess or .htpasswd file in my main www directory at all, or any of the sub directories for that matter.

edit:  I am using Windows 2000 Server.  Is it possible that the .htaccess file is hidden?  I set Folder Options to "show hidden files and folders" and even disabled "hide protected os files" and still don't see any.  Are there some access settings in the security tab of the folders that I have to change?

edit: from a somewhat similar post...

A. Do you have Skype installed?
nope, this prob isn't related.

B. Do you have an Anti-Virus Software Installed?
AVG 6.0 but I used to use IIS on 80 and it worked fine (IIS is not completely uninstalled).

C. Is your Anti-Virus Software blocking port 80?
Prob not, see above.

D. Do you have a drive on your PC already named W:/?
Nope, just my main HD.

E. Do you have any other programs that might be using or blocking port 80?
DynDNS updater and NO-IP DUC but I believe these use alt ports and not port 80.

F. Do you have a drive named W:/?
I have a drive named W but only after I use start.bat so it is the Uniserver drive.

G. What OS is your computer running?
Windows 2000 Server

H. What error does it bring up?
Worked fine when I access it from within my computer i.e. http://localhost but when trying to access from outside network

View Post



my problem was solved just by refreshing as Oji suggested
JH




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users