Jump to content


Photo

What is wrong with my vhosts settings?

vhosts

  • Please log in to reply
2 replies to this topic

#1 richfieldmall

richfieldmall

    Newbie

  • Member
  • Pip
  • 7 posts
  • Main OS: Windows 7

Posted 12 April 2017 - 02:25 PM

What have I done wrong with my vhosts setup? 
 

The first site I set up is running well in vhosts. No problems other than occasional crashes (starwarswisdom.com).  

 

Then, to develop a second wordpress site (richfieldmall.com), I created this second website on C:\UniServerZ\www.  

Then I created a new vhosts location via the controller interface (stop Apache, then go Apache > Apache vhosts > Create... so easy!).

 

Then, I cut and pasted the site over into the new, corresponding directory under C:\UniServerZ\vhosts.

 

Was that the wrong way to do that?

 

My current configuration points traffic for the second site, richfieldmall.com, toward the default Uniform Server test page, under /www, instead of over to /vhosts

 

 

My settings are as follows:

 

 

.htaccess:

#------------------------------------------------------------------------------
# This file provides server security limiting access to the localhost only.
# Comment next four lines to deactivate. (Allows external access)
#------------------------------------------------------------------------------

#Order Deny,Allow
Allow from all
#Allow from 127.0.0.1
#Allow from ::1

#------------------------------------------------------------------------------
# To allow execution of cgi scripts in this directory uncomment next two lines.
#------------------------------------------------------------------------------.

AddHandler cgi-script .bat .exe .pl .cgi
Options +ExecCGI +FollowSymLinks


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

C:\UniServerZ\core\apache2\conf\extra:

<VirtualHost _default_:80>
  DocumentRoot C:/UniServerZ/www
  ServerName localhost
  ErrorLog "logs/error.log"
  CustomLog "logs/access.log" common
</VirtualHost>

<VirtualHost *:80>
 ServerAdmin webmaster@starwarswisdom.com
 DocumentRoot C:/UniServerZ/vhosts/starwarswisdom
 ServerName starwarswisdom.com
 ServerAlias www.starwarswisdom.com *.starwarswisdom.com
 ErrorLog logs/starwarswisdom.com-error.log
 CustomLog logs/starwarswisdom.com-access.log common
 <Directory "C:\UniServerZ\vhosts\starwarswisdom">
   Options Indexes Includes
   AllowOverride All  
   Require all granted
 </Directory>
</VirtualHost>

<VirtualHost *:${AP_PORT}>
 ServerAdmin webmaster@richfieldmall.com
 DocumentRoot ${US_ROOTF}/vhosts/richfieldmall
 ServerName richfieldmall.com
 ServerAlias www.richfieldmall.com *.richfieldmall.com
 ErrorLog logs/richfieldmall.com-error.log
 CustomLog logs/richfieldmall.com-access.log common
 <Directory "${HOME}\vhosts\richfieldmall">
   Options Indexes Includes
   AllowOverride All  
   Require all granted
 </Directory>
</VirtualHost>

If any other information is needed, please let me know. Advice, suggestions, links -- any info is welcome!

 



#2 richfieldmall

richfieldmall

    Newbie

  • Member
  • Pip
  • 7 posts
  • Main OS: Windows 7

Posted 29 April 2017 - 12:27 AM

I researched this over and over and was unable to remedy this issue. As a result, we are switching our site to a paid hosting platform.

Sad to see such a promising project -- easily offering a grander future than WordPress, etc. -- wallow in apparent inattention(?). 



#3 slappycat

slappycat

    Newbie

  • Member
  • Pip
  • 1 posts
  • IRC Nickname: swenlarsen
  • Main OS: Windows 7

Posted 30 August 2019 - 06:26 AM

I'm having the same problems with the Aug2019 release.

 

It worries me that there has been almost zero discussion about vhosts not working (worked fine in the last version) and not in this new release.

 

I guess it's time to move on.







Also tagged with one or more of these keywords: vhosts

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users