Jump to content


Photo

PEAR


  • Please log in to reply
4 replies to this topic

#1 0livier

0livier

    Newbie

  • Member
  • Pip
  • 5 posts

Posted 03 September 2005 - 12:59 PM

Hi,

Facts
====
- I'm using WinXP.
- I've downloaded and unzipped UniServer 3.2a. (d:\server\uniserver\)
- Using the adminstration interface, I launched the go-pear script.
- I've chosen not to installed the additional package and
- I've accepted the default installation parameters.
- Everything's fine (100% done) but the warning message:

"Warning: Go-PEAR was not able to determine the URL to the newly installed
Web Frontend of the PEAR Installer. Please access it manually. Since you
specified the prefix, you should know how to do so."

- I've checked the include_path variable in php.ini : it contains the path to PEAR.

Objective
=======
- I wish to launch the PEAR Package Manager

Attempts
======
- With my browser I've tried to open these files:
- http://localhost/W:/...l/Php/index.php => 403 FORBIDDEN
- file://localhost/W:/usr/local/Php/index.php => unprocessed index.php
- http://localhost/usr.../PEAR/index.php => 404 NOT FOUND
- http://localhost/index.php => NOT FOUND
- I thought the server might need a stop/start:
- I've tried the same files but nothing changed

Questions
=======
- What did I do wrong?
- What do I have to do?

Many thanks in advance!

#2 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,348 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 06 September 2005 - 05:37 PM

Go to http://go-pear.org and download the latest installer. Replace it with the one in the Uniform Server installation and run it.

#3 genderboy

genderboy

    Junior Member

  • Member
  • Pip
  • 17 posts

Posted 04 March 2006 - 09:43 AM

hi there is an article related to this error, i have the same problem as you, i read this article and there were some points which i tried but with no success, but maybe you will be luckier than i

http://forum.uniform...hp?showtopic=33

#4 pixelsoul

pixelsoul

    Junior Member

  • Member
  • Pip
  • 38 posts

Posted 11 March 2006 - 09:01 AM

with 3.3 i always get this error at 70%

ok
Bootstrapping: Archive_Tar............(remote) ok
Bootstrapping: Console_Getopt.........(remote) ok
Downloading package: DB...............ok
Downloading package: Net_Socket.......ok
Downloading package: Net_SMTP.........ok
Downloading package: Mail.............ok
Downloading package: XML_Parser.......ok
Downloading package: PHPUnit..........ok

Fatal error: Class 'PEAR' not found in W:\home\admin\www\plugins\pear\go_pear.php on line 668

#5 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,348 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 23 March 2006 - 11:25 PM

There is another thread here that shows how you can solve this using a bat file and other methods known.

Please check this forum and other forums.

Thanks.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users