Jump to content


Photo

Failed to Start MySQL

MySQL problem falled to start

  • Please log in to reply
3 replies to this topic

#1 hommealone

hommealone

    Newbie

  • Member
  • Pip
  • 5 posts
  • Main OS: Windows XP

Posted 17 September 2014 - 03:32 PM

I've been running UniServer Zero for quite a while without problems. I run it from an external hard drive. I am running version UniServer Zero XI 11.0.7 with UniController XI V1.0.6. (On WinXP).

 

Today when I started the controller, (in the same environment as usual, no changes to system since last run), I clicked 'Start Apache' as usual without problem. Then when I clicked 'Start MySQL', I got Warning: Failed to start MySQL

 

I looked in mysql.err error log and found:

 

140917 13:06:38 [Note] Plugin 'FEDERATED' is disabled.
140917 13:06:38 InnoDB: The InnoDB memory heap is disabled
140917 13:06:38 InnoDB: Mutexes and rw_locks use Windows interlocked functions
140917 13:06:38 InnoDB: Compressed tables use zlib 1.2.3
140917 13:06:38 InnoDB: Initializing buffer pool, size = 16.0M
140917 13:06:38 InnoDB: Completed initialization of buffer pool
140917 13:06:40 InnoDB: highest supported file format is Barracuda.
140917 13:06:40  InnoDB: Waiting for the background threads to start
140917 13:06:41 InnoDB: 5.5.35 started; log sequence number 1595675
140917 13:06:41 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
140917 13:06:42 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
140917 13:06:42 [Note] Server socket created on IP: '127.0.0.1'.
140917 13:06:43 [Note] Event Scheduler: Loaded 0 events
140917 13:06:43 [Note] E:\UniServerZ\core\mysql\bin\mysqld_z.exe: ready for connections.
Version: '5.5.35'  socket: ''  port: 3306  MySQL Community Server (GPL)
140917 13:07:07 [Note] Plugin 'FEDERATED' is disabled.
140917 13:07:07 InnoDB: The InnoDB memory heap is disabled
140917 13:07:07 InnoDB: Mutexes and rw_locks use Windows interlocked functions
140917 13:07:07 InnoDB: Compressed tables use zlib 1.2.3
140917 13:07:08 InnoDB: Initializing buffer pool, size = 16.0M
140917 13:07:08 InnoDB: Completed initialization of buffer pool
140917 13:07:08  InnoDB: Operating system error number 32 in a file operation.
InnoDB: The error means that another program is using InnoDB's files.
InnoDB: This might be a backup or antivirus software or another instance
InnoDB: of MySQL. Please close it to get rid of this error.

 

From a command prompt I ran:
netstat -b -p TCP

but I couldn't find anything that was using the port.

 

After clicking the 'Start MySQL' button a few more times, I also got:

MySQL port = 3306
Application PID = 3136
Application Name = MYSQLD_Z.EXE
Application Path = E:\UniServerZ\core\mysql\bin\mysql_z.exe

 

I found MYSQLD_Z.EXE in Windows Task Manager (Multiple instances) and used 'end process' to terminate them. But still no luck.

 

I restarted windows but still found the same problem. I can't start MySQL.

 

Please help! What can I do?

 

I've attached a copy of the complete error log.

Attached Files



#2 hommealone

hommealone

    Newbie

  • Member
  • Pip
  • 5 posts
  • Main OS: Windows XP

Posted 17 September 2014 - 04:26 PM

Note also:

 

Although I received the Failed to start MySQL warning and the controller shows that MySQL is not running, when I open a website in my browser, which I am developing locally using UniserverZ, the website opens and operates properly. I can edit and save things which are part of the database. This suggests that MySQL is running, no?



#3 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 24 September 2014 - 01:23 PM

There have been many changes since UniController XI V1.0.6. upgrade to ZeroXI_controller_1_1_6

Download ZeroXI_controller_1_1_6.exe save to a temp folder. Double click file to extract.
Copy file UniController.exe to folder UniServerZ

There have been several security updates ideally update to Uniform Server 11_3_3_ZeroXI

All the best
Ric



#4 hommealone

hommealone

    Newbie

  • Member
  • Pip
  • 5 posts
  • Main OS: Windows XP

Posted 24 September 2014 - 02:01 PM

Thanks Ric.

 

The problem I posted about has gone away. I don't know what caused it originally or what cleared it up; sorry, I'm no help to anyone in the future with a similar problem.

 

Thanks for your advise to update. I'd like to. I have searched the Wiki and also Googled, but can't find instructions on updating to a newer version. Can you point me at those?

 

I could simply install the newest version in a different directory; in that case I'd need instructions on how to move the sites in the first installation to the second installation. Is it any more involved than simply copy/pasting the www folder? I imagine that my database, Apache or MySQL configurations are not in the www directory...






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users